Ubuntu 20.04 Focal + NGINX 1.23

jitsi-installer.sh.txt (21.0 KB)
@emrah
Could you be so kind and check why, after using this script, the new installtion does not work?
The NGINX version 1.23 does not create the directories under /etc/nginx/ for this I added it in the script
Using this script with the older NGINX with lua support did work very nice.
Now with the new version NGINX I see the https page but firefox can’t open the site as I get end of file error.
I do see the HTTPS in the browser

Please give me some hints to find the error, then will test and send you the working script

Greetings,

Ronald

IIUC this is a customized Ubuntu setup. I have no time for now to analyze it in detail. Use a standart/uncustomized Ubuntu 20.04 if it’s OK for your use case.

The used Ubuntu is a standard one with before the NGINX version 1.18 which give me sites problems.
I got certificates from other configuration on the same installation and unable to solve it.
I hope with version 1.23 this will be solved but run now against the problems that jitsi-meet doesn’t become visible in the browser
I have no idea where to start with problem solving.

All problems solved I do see that NGINX 1.18 is installed and the error with certficates is solved
The error was in the script:
The original line had as path /var/www/html.
After changing all went fine
certbot certonly --dry-run --non-interactive -m info@$JITSI_HOST --agree-tos
–duplicate --webroot -w /usr/share/jitsi-meet -d $JITSI_HOST,$TURN_HOST || true
sleep 3
certbot certonly --non-interactive -m info@$JITSI_HOST --agree-tos
–duplicate --webroot -w /usr/share/jitsi-meet -d $JITSI_HOST,$TURN_HOST

1 Like

Good catch!

I think the issue arised in your script because of the commented rm lines:

ln -s /usr/local/share/nginx/modules-available/jitsi-meet.conf \
    /etc/nginx/modules-enabled/99-jitsi-meet-custom.conf
#rm /etc/nginx/sites-enabled/default
#rm -rf /var/www/html
ln -s /usr/share/jitsi-meet /var/www/html