Ubuntu 18.04: Problem with letsencrypt script

Hello.
After hours and hours I decided to ask for help because I´m going mad.

I followed the steps listed in the Jitsi-Meet quick install guide and succeed installing Jitsi with self signed certificate.

When I try to generate a Let’s Encrypt certificate I receive the following output:

root@jitsi:/home/hrmtc# sh /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh
-------------------------------------------------------------------------
This script will:
- Need a working DNS record pointing to this machine(for domain -ejitsi.rata.net)
- Download certbot-auto from https://dl.eff.org to /usr/local/sbin
- Install additional dependencies in order to request Let’s Encrypt certificate
- If running with jetty serving web content, will stop Jitsi Videobridge
- Configure and reload nginx or apache2, whichever is used
- Configure the coturn server to use Let's Encrypt certificate and add required deploy hooks
- Add command in weekly cron job to renew certificates regularly

You need to agree to the ACME server's Subscriber Agreement (https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf)
by providing an email address for important account notifications
Enter your email and press [ENTER]: mymail@gmail.com
--2020-04-15 22:10:12--  https://dl.eff.org/certbot-auto
Resolving dl.eff.org (dl.eff.org)... 151.101.192.201, 151.101.128.201, 151.101.64.201, ...
Connecting to dl.eff.org (dl.eff.org)|151.101.192.201|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 80073 (78K) [application/octet-stream]
Saving to: ‘certbot-auto’

certbot-auto                     100%[==========================================================>]  78.20K  --.-KB/s    in 0.008s

2020-04-15 22:10:13 (9.09 MB/s) - ‘certbot-auto’ saved [80073/80073]

root@jitsi:/home/hrmtc#

If I run the script again, it jump to prompt without any output.
I double checked every step including DNS, domain and port forwarding configuration.

Any guidance will be much appreciated.
Thanks! :pray:

I want to share the solution in case anyone is experience the same problem:

If you want to reinstall your server utilizing the same subdomain than before, first you must revoke your letsencrypt certificate running the following command:

certbot revoke --cert-path /etc/letsencrypt/live/subdomain.yourdomain.com/cert.pem

Only then you will be able to run the script located at /usr/share/jitsi-meet/scripts/ succesfully.

:laughing: :pray:

2 Likes