Ubuntu 18.04 LTS install guide fails since the release of Prosody 0.2

On Ubuntu 18.04 LTS the installation as described in the setup guide fails since the Prosody 0.2 release. As a workaround I have been installing the prosody-0.11 package before installing the jitsi-meet package. I haven’t tried the installation on an Ubuntu 20.04 but I can’t see how the results would be different.

ERRORS

Setting up jitsi-meet-prosody (1.0.5913-1) ...
/usr/bin/env: ‘lua’: No such file or directory
dpkg: error processing package jitsi-meet-prosody (--configure):
 installed jitsi-meet-prosody package post-installation script subprocess returned error exit status 127
Setting up binutils (2.30-21ubuntu1~18.04.7) ...
Setting up gcc-7 (7.5.0-3ubuntu1~18.04) ...
Setting up g++-7 (7.5.0-3ubuntu1~18.04) ...
dpkg: dependency problems prevent configuration of jitsi-meet:
 jitsi-meet depends on jitsi-meet-prosody (= 1.0.5913-1); however:
  Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up gcc (4:7.4.0-1ubuntu2.3) 
dpkg: dependency problems prevent configuration of jitsi-meet-turnserver:
 jitsi-meet-turnserver depends on jitsi-meet-prosody; however:
  Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet-turnserver (--configure):
 dependency problems - leaving unconfigured
Setting up dpkg-dev (1.19.0.5ubuntu2.3) ...No apport report written because the error message indicates its a followup error from a previous failure.

...

Errors were encountered while processing:
 jitsi-meet-prosody
 jitsi-meet
 jitsi-meet-turnserver
E: Sub-process /usr/bin/dpkg returned an error code (1)
...


FIX

echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
wget https://prosody.im/files/prosody-debian-packages.key -O- | apt-key add -
apt-get update
apt-get install -y prosody-0.11
sudo apt install

Couple of questions:

  • Is this the recommended approach and correct version of Prosody package to install as a workaround?
  • Will the jitsi-meet package be updated to correctly to reflect the 0.11 dependency?

-Roberto

Yep.

We are testing and moving to prosody 0.12 and there is no need to change anything in jitsi-meet dependencies.

Maybe ask in the prosody community about the problem of running 0.12 on 18.04, I have no idea what is the problem. If you figure it out you and create a PR to the quick install 18.04 section for a fix.

I did a quick test install yesterday on Ubuntu 18.04 LTS – it appears prosody has dropped all 0.11.* versions from the prosody repo which means apt install prosody can only give you 0.12 with no older 0.11.* versions in the version table.

While you can get a 0.11 version using the prosody-0.11 package, I’m not sure that gives you the latest 0.11.13. I was able to successfully install Jitsi using that package but JWT auth didn’t work. A quick snoop around lead to realisation that session.auth_token was not set because “websocket-session” event was not triggered (added in v0.11.6). (edit: this statement proved to be inaccurate)

In the end, to get to a working setup, we had to install 0.11.13 using the .deb files directly and manually installing the dependencies. Not sure this is the best way to do it, but it appeared to work in our test deployment.

# Manually install dependencies
apt-get install -y lua5.2 liblua5.2 lua-expat lua-filesystem lua-socket ssl-cert
# get .deb file directly form prosody server. 
# If your arch is different, change the "amd64" bit accordingly
curl https://packages.prosody.im/debian/pool/main/p/prosody/prosody_0.11.13-1~bionic1_amd64.deb -o prosody_0.11.13.deb
dpkg -i prosody_0.11.13.deb

# Install Jitsi the usual way...
2 Likes

Thanks for the information @damencho !

Thanks @shawn I suspected there were some issues related to using the prosody-0.11 package, I had not been able to prove it though. I had not considered using the .deb files directly, I will adjust my scripts to do this as it should be more stable and up to par with what we had before the prosody 0.2 release.
-Roberto

1 Like

Hi @shawn,

The prosody package install with apt install prosody-0.11 is a nigthly build version of the 0.11 branch from the release date of version 0.11.13 (24/01/2022) and it should be quite similar to the prosody_0.11.13 version.
That’s strange you observe this issue with websocket-session event.

That’s what I thought (hoped), but alas didn’t seem to work as expected. Perhaps it’s an issue specific to bionic build?

You’re right. I checked. It does match the head of 0.11 branch. No idea why JWT auth failed with I tried it :person_shrugging: