Ubunttu 16 Install-letsencrypt-cert.sh fails - Failed authorization procedure

I’ve recently had to go back from Ubuntu 18 to 16 in order to install snd-aloop to jibri working. IF THERE IS A WAY TO GET JIBRI WORKING IN UBUNTU 18, PLEASE STOP ME NOW!

So I started my installation process:

udo hostnamectl set-hostname meet.mydomain.com

sudo nano /etc/hosts
#manually append 
#127.0.0.1 meet.mydomain.com

wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -
echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list

sudo apt-get -y update
sudo apt-get -y install prosody

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add -
sudo sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"

sudo apt-get -y update
sudo apt-get -y install jitsi-meet

#manually type
#meet.mydomain.com
#choose self-signed cert for now

sudo add-apt-repository ppa:certbot/certbot
sudo apt -y install certbot

But then Nginx doesn’t work with the current TLS levels defined. So I had to upgrade nginx. I followed this process here: https://askubuntu.com/questions/1147144/how-to-upgrade-nginx-on-ubuntu-16-04

With Nginx now working, tried to install the cert

sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

And I get the following

Enter your email and press [ENTER]: development@example.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for meet.example.com
Using the webroot path /usr/share/jitsi-meet for all unmatched domains.
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. meet.example.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://meet.example.com/.well-known/acme-challenge/NDY2fMwEREJnVaXDIEqJlXTcfrf-NwMno22lT1VR5Xc [x.xxx.xx.xxx]: "<html>\r\n<head><title>404 Not Found</title></head>\r\n<body>\r\n<center><h1>404 Not Found</h1></center>\r\n<hr><center>nginx/1.19.3</ce"

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: meet.example.com
   Type:   unauthorized
   Detail: Invalid response from
   http://meet.example.com/.well-known/acme-challenge/NDY2fMwEREJnVaXDIEqJlXTcfrf-NwMno22lT1VR5Xc
   [34.238.27.182]: "<html>\r\n<head><title>404 Not
   Found</title></head>\r\n<body>\r\n<center><h1>404 Not
   Found</h1></center>\r\n<hr><center>nginx/1.19.3</ce"

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain

My nginx sites enable contains the following:

server {
    listen 80;
    listen [::]:80;
    server_name meet.example.com;

    location ^~ /.well-known/acme-challenge/ {
       default_type "text/plain";
       root         /usr/share/jitsi-meet;
    }

    location /.well-known {
       root /usr/share/jitsi-meet;
    }

    location = /.well-known/acme-challenge/ {
       return 404;
    }
    location / {
       return 301 https://$host$request_uri;
    }
}

Any idea of why this is happening?