Two broswers opened in the same room but they don't see each other [SOLVED]


I’m continuing my journey to make jitsi to work.

Right now, I’m able to see the jitsi page (dark blue background). I can see myself on the loopback video, etc.

However, I open the same URL (room) on two different browers but they don’t see themselves as if they are different users.
They see themselves as if they are alone in the room.
I tried a 3rd browser and it’s like it’s alone in the room also. It’s like the same room with the same name is in its ownspace/dimension.

What’s wrong ?

Javascript console, normally start from there, do you see any errors? Attaching the console will help.

Thank you for your answer.

a) If I enter something in the chat window, nothing appear in the console (F12 on the browser)
b) If I reload the page I have some errors but they don’t seem to be related to my problem

LocalStatsCollector.js:22 The Web Audio autoplay policy will be re-enabled in Chrome 70 (October 2018). Please check that your website is compatible with it.
[modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for undefined
[JitsiMeetJS.js] <Object.init>: Analytics disabled, disposing.
[modules/statistics/AnalyticsAdapter.js] <e.value>: Disposing of analytics adapter.

I don’t see anything abnormal.

Nothing in prosody.err

Otherwise I see a continuous loop like this

[modules/xmpp/moderator.js] <i.createConferenceIq>: Session ID: null machine UID: f257a0d963612944fc3300f61c9c5909
[modules/xmpp/moderator.js] <i.parseConfigOptions>: Authentication enabled: false
[modules/xmpp/moderator.js] <i.parseConfigOptions>: External authentication enabled: false
[modules/xmpp/moderator.js] <i.parseConfigOptions>: Sip gateway enabled: false
[modules/xmpp/moderator.js] <i._allocateConferenceFocusSuccess>: Waiting for the focus… 512000

That’s strange, if participant do not see each other(not like audio video, but you don’t see any participant’s thumbnail in the room) and you have one server, than they must be having problem connecting to the muc … check prosody logs.

Is this correct, when you say

you don’t see any remote participant thumbnail?

If the problem is that there is no audio and video, the problem usually is not following the settings needed for NAT (when jvb is behind NAT)

Thank you for your answer.

So, regarding the /etc/jitsi/videobridge/ file, nginx is chrooted so the www user doesn’t have access to the /etc tree.
I just copied it into /var/www/etc/jitsi/videobridge/ but no luch that didn’t help

There’s nothing in the prosody.debug logs that would tell me something

But the jicofo logs look like this

Jicofo 2018-11-10 00:14:11.039 INFO: [61] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().402 Focus request for room:
Jicofo 2018-11-10 00:14:14.586 INFO: [13] org.jitsi.jicofo.FocusManager.log() Focus idle timeout for
Jicofo 2018-11-10 00:14:18.837 INFO: [63] org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().402 Focus request for room:
Jicofo 2018-11-10 00:14:19.595 INFO: [13] org.jitsi.jicofo.FocusManager.log() Focus idle timeout for
Jicofo 2018-11-10 00:14:24.604 INFO: [13] org.jitsi.jicofo.FocusManager.log() Focus idle timeout for

The video bridge logs like this

INFO: CAT=stat create_conf,conf_id=7c06c8cc2687f6ce conf_name=null,logging=false,conf_count=1,ch_count=0,v_streams=0
Nov 10, 2018 12:15:47 AM org.jitsi.util.LoggerImpl log
INFO: Performed a successful health check in 13ms. Sticky failure: false

You didn’t answer any of my questions, is it a media problem or you don’t see other participants thumbnails?

I don’t understand what nginx needs to have in common with jvb.

Yes sorry, it was clear for me but maybe not in my text.
=> I just see ONE thumbnail

When I start videobridge I see

INFO: Not starting the Jetty service for
INFO: Using, face=/JVBPRIV@, mask=/MYPUB@
I don’t know what is this port 8080

You have a signalling problem, it cannot reach the state to use jvb at all, your participants are not joining the muc this should be fixed first.

Thank you for your answer.

I didn’t understand what component should I start with my troubleshooting.

it cannot reach the state to use jvb at all
It stands for jifoco ?

I checked that port (both tcp and udp right now) 4443 and 10000 to 20000 go to the machine hosting jifoco and jvb.

i read this message

So the first thing is to identify a message from a web client with an iq in prosody ?

I see this in the prosody debug logs

Nov 10 11:37:04 mod_bosh debug Handling new request table: 0x48ab141c000: <body rid='2776532440' xmlns='' sid='f3961359-88ca-4dd9-b39b-57f5f347233d'><iq to='' type='set' xmlns='jabber:client' id='cceb69e9-034f-4f58-857f-05193c675a56:sendIQ'><conference xmlns='' room='' machine-uid='f257a0d963612944fc3300f61c9c5909'><property name='channelLastN' value='-1'/><property name='disableRtx' value='false'/><property name='enableLipSync' value='true'/><property name='openSctp' value='true'/></conference></iq></body>

Or should I check again the communication between jicofo and prosody ?

I have this in my prosody config

Component “” “muc”

So here is how things work.

  1. The client loads the UI and sends a conference iq to jicofo (the iq message you have posted above)
  2. Jicofo checks and if the conference does not exists, creates the room and joins there
  3. The client receives answer for the conference iq and enters the room
  4. A second participant joins, jicofo sees that and invites both participants
  5. Both participants exchange invitations to each other for p2p connection
  6. media starts to flow direct between peers if possible (p2p succeeds) or everybody starts sending to jvb and jvb starts sending to the other participant

So in your case, when everybody join but see as only they are in the room, you don’t see the remote participants thumbnail, this most probably means that your deployment breaks on step 3, where client needs to join the muc, when it joins it will receive information that there are remote participants and will create thumbnails for them (black thumnails with no audio/video, maybe just display name).

You must first see remote participants thumbnails, even without media flowing. So what I meant is that, there is no point to check jvb, cause it is on step 6, where if I’m reading your explanation right, your deployment is broken before even jicofo contacts jvb to open channels and before the clients start sending data to jvb.


Thank you very much for this explanation.
After 48h off, I restarted to troubleshoot and quickly found the problem.
I wrote*

instead of*

I know it’s so stupid.

The thing I noticed with Jitsi is once you get an error, it’s very difficult to troubleshoot because in the first place it’s not clear how components talk to another (I read the docs).
For example your explanation is very clear and your message

You have a signalling problem, it cannot reach the state to use jvb at all, your participants are not joining the muc this should be fixed first.

Tells something to start a troubleshooting.

Which error message could have told me I didn’t have the right AUTHORIZED_SOURCE_REGEXP


Hi there,
I am facing the same problem after installing Jitsi to a vServer running Ubuntu 18.04.
I can reach the server and open a room, but if another Person tries to enter it, it seems to open a new room. Also connecting via App does not work at all (neither Android, nor iOS).
@Mikygee, where exactly did you write that? I am pretty new into this topic and I don’t really remember writing anything like that…


Did you ever find the solution to this ?
I just did a second install using the install guide and nothing is working (same symptoms as you) along with a disconnect every 30 seconds

At that time yes I solved my problem.

I have the same issue as above with a redundant question.

Can you tell me in a little more detail where you find Authorized_Source_Regexp?

Thank you very much

the issue is the prosody is not connected, i did purge everything, then install jitsi-meet but first i remove a repository for prosody from the source list, this is why if you install the jitsi-meet with the latest version of prosody 0.11 the installer does not install properly prosody files. so the installer installs the prosody version 0.10 then with this version prosody files will be correct created and saved