Tutorial: Loadtesting Jitsi with MalleusJitsificus on a Selenium Grid

This looks like not enough resources for Chrome, for these tests 4GB of RAM and few cores (2 or 4) are needed per instance.

@damencho Can you please help me on video not playing issue I have specified above Tutorial: Loadtesting Jitsi with MalleusJitsificus on a Selenium Grid - #87 by manpreets.narang

I think you should have one with video and 2 with audio. What do you see, can you upload a screenshot?

@damencho plz check screenshot here: http://prntscr.com/10v6lum

The resources/FourPeople_1280x720_30.y4m file needs to be installed on the Selenium grid nodes – it’s not automatically copied from your Malleus installation. They need to be placed under the remote.resource.path (which is set to /usr/share/jitsi-meet-torture in the standard malleus.sh script).

So the full location of the file should be /usr/share/jitsi-meet-torture/resources/FourPeople_1280x720_30.y4m on every Selenium grid node.

@Jonathan_Lennox Yes, I already have that… Copied the resources folder on all nodes already and have the required files on the mentioned location . As I mentioned above earlier using this way Audio file is working but Video is not. Any Other suggestions?

I believe the possible reason can be that all the participants sent from Jitsi torture script have their video disabled. I am not sure if we can force anyway to enable it. Still waiting for @damencho thoughts as I have uploaded the screenshot he has asked for.

Yeah, I saw the screenshot where all participants are video muted, that’s why I asked Johnathan for help :slight_smile:

oh ok… @Jonathan_Lennox anything else that I can check at my end?

1 Like

Hi, i have set up a configuration too and my video is not displaying also. Maybe someone can tell me if there is something wrong, maybe my chrome version having trouble with y4m? I have build it half a year on my PC and it worked with the same video.

Now on AWS the tester join the hamertesting0, camera icon vanish but no video. Same for audio, but audio is not what i need.

My configuration:
AWS EC2 t2.medium with Amazon Linux 2 AMI
ChromeDriver 89.0.4389.23
Google Chrome 89.0.4389.114
selenium/hub:3.141.59-20200525
selenium/node-chrome:3.141.59-20210311
jitsi-meet-torture is the current master
The Files are located in the nodes at /usr/share/jitsi-meet-torture/resources
The File itself is FourPeople_1280x720_60.y4m (I changed the Hard coded File in jitsi-meet-torture to this name too)

EDIT: I tried this configuration on my local setup. Video is working.

I solved it.
My problem was homemade. My problem was at the configuration of aws security policies. My outgoing traffic was just allowed for tcp connections.

@Jonathan_Lennox Hello, any solution for this bug? I have the same thing here, can’t see any video launched. I wonder if a Linux Desktop Environments with some modules is requeired on the server of test? Thanks for help.

This is how I run Malleus test

  1. Enable AutoPlayVideo in jitsi-meet-torture
    cd /opt/jitsi-meet-torture
    sed -i 's/noAutoPlayVideo=true/noAutoPlayVideo=false/' src/test/java/org/jitsi/meet/test/MalleusJitsificus.java

https://media.xiph.org/video/derf/y4m/FourPeople_1280x720_60.y4m

  1. Generate FourPeople_1280x720_30.y4m for jitsi-meet-torture
    cd /opt/jitsi-meet-torture
    ffmpeg -i resources/FourPeople_1280x720_60.y4m -vf fps=fps=30 resources/FourPeople_1280x720_30.y4m
  1. Give RO access to /opt/jitsi-meet-torture
    cd /opt/jitsi-torture-selenium-grid-platform/hub/
    sed -i "11a\ - /opt/jitsi-meet-torture:/usr/share/jitsi-meet-torture:ro" docker-compose.yml
    (6 spaces between ‘\ -’)
    docker-compose up -d --scale chrome=10

  2. Run the test
    cd /opt/jitsi-meet-torture/
    ./scripts/malleus.sh --instance-url='https://meet.domain.com' --conferences=10 --participants=3 --senders=1 --audio-senders=1 --duration=600