TUTORIAL: Jibri Overview, Troubleshooting Tips & Tricks - Solve your Jibri Problems, Quickly!

@Freddie @emrah

I’m facing same issue, I’m using jibri.conf as per new releases and not using the config.json file:

here are my logs:

2021-04-29 19:50:51.020 INFO: [1] org.jitsi.jibri.Main.log() Jibri run with args [--config, /etc/jitsi/jibri/config.json]
2021-04-29 19:50:51.220 INFO: [1] org.jitsi.jibri.Main.log() Checking legacy config file /etc/jitsi/jibri/config.json
2021-04-29 19:50:51.220 INFO: [1] org.jitsi.jibri.Main.log() Legacy config file /etc/jitsi/jibri/config.json doesn't exist
2021-04-29 19:50:51.451 INFO: [1] org.jitsi.jibri.Main.log() Jibri starting up with id netvest1
2021-04-29 19:50:53.531 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.log() got jwtConfig: {}

2021-04-29 19:50:53.531 INFO: [1] org.jitsi.jibri.webhooks.v1.JwtInfo.log() Unable to create JwtInfo: com.typesafe.config.ConfigException$Missing: /etc/jitsi/jibri/jibri.conf: 79: No configuration setting found for key 'signing-key-path'
2021-04-29 19:50:53.682 INFO: [1] org.jitsi.jibri.Main.log() Using port 3333 for internal HTTP API
2021-04-29 19:50:53.696 FINE: [17] org.jitsi.jibri.webhooks.v1.WebhookClient.log() Updating 0 subscribers of status
2021-04-29 19:50:54.274 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.log() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2021-04-29 19:50:54.280 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.log() Connecting to xmpp environment on netvest-meet.com with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[netvest-meet.com], xmppDomain=netvest-meet.com, controlLogin=XmppCredentials(domain=auth.netvest-meet.com, username=jibri, password=jibriauthpass), controlMuc=XmppMuc(domain=internal.auth.netvest-meet.com, roomName=JibriBrewery, nickname=jibri-nickname), sipControlMuc=null, callLogin=XmppCredentials(domain=recorder.netvest-meet.com, username=recorder, password=jibrirecorderpass), stripFromRoomDomain=conference., usageTimeoutMins=0, trustAllXmppCerts=true)
2021-04-29 19:50:54.280 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.log() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2021-04-29 19:50:54.295 INFO: [1] org.jitsi.jibri.Main.log() Using port 2222 for HTTP API
2021-04-29 19:50:54.296 WARNING: [26] org.jitsi.xmpp.mucclient.MucClient.log() Disabling certificate verification!
2021-04-29 19:50:54.624 INFO: [26] org.jitsi.xmpp.mucclient.MucClient.log() Connected.
2021-04-29 19:50:54.624 INFO: [26] org.jitsi.xmpp.mucclient.MucClient.log() Logging in.
2021-04-29 19:50:54.681 INFO: [26] org.jitsi.xmpp.mucclient.MucClient.log() Joined MUC: jibribrewery@internal.auth.netvest-meet.com
2021-04-29 19:50:56.431 INFO: [43] org.jitsi.jibri.api.http.internal.InternalHttpApi.log() Jibri gracefully shutting down
2021-04-29 19:50:56.452 INFO: [46] org.jitsi.jibri.Main.log() Jibri has been told to graceful shutdown, waiting to be idle before exiting
2021-04-29 19:50:56.452 INFO: [46] org.jitsi.jibri.Main.log() Jibri is idle and has been told to gracefully shutdown, exiting

Also here’s my jibri.conf file, I even checked this link for troubleshooting and everything seems to be fine, also Ive added 777 permissions too! Not sure what’s happening wrong here

jibri {
  // A unique identifier for this Jibri
  // TODO: eventually this will be required with no default
  id = "netvest1"
  // Whether or not Jibri should return to idle state after handling
  // (successfully or unsuccessfully) a request.  A value of 'true'
  // here means that a Jibri will NOT return back to the IDLE state
  // and will need to be restarted in order to be used again.
  single-use-mode = false
  api {
    http {
      external-api-port = 2222
      internal-api-port = 3333
    }
    xmpp {
      // See example_xmpp_envs.conf for an example of what is expected here
      environments = [
	      {
                name = "prod environment"
                xmpp-server-hosts = ["netvest-meet.com"]
                xmpp-domain = "netvest-meet.com"

                control-muc {
                    domain = "internal.auth.netvest-meet.com"
                    room-name = "JibriBrewery"
                    nickname = "jibri-nickname"
                }

                control-login {
                    domain = "auth.netvest-meet.com"
                    username = "jibri"
                    password = "jibriauthpass"
                }

                call-login {
                    domain = "recorder.netvest-meet.com"
                    username = "recorder"
                    password = "jibrirecorderpass"
                }

                strip-from-room-domain = "conference."
                usage-timeout = 0
                trust-all-xmpp-certs = true
            }]
    }
  }
  recording {
    recordings-directory = "/srv/recordings"
    # TODO: make this an optional param and remove the default
    finalize-script = "/path/to/finalize_recording.sh"
  }
  streaming {
    // A list of regex patterns for allowed RTMP URLs.  The RTMP URL used
    // when starting a stream must match at least one of the patterns in
    // this list.
    rtmp-allow-list = [
      // By default, all services are allowed
      ".*"
    ]
  }
  ffmpeg {
    resolution = "1920x1080"
    // The audio source that will be used to capture audio on Linux
    audio-source = "alsa"
    // The audio device that will be used to capture audio on Linux
    audio-device = "plug:bsnoop"
  }
  chrome {
    // The flags which will be passed to chromium when launching
    flags = [
      "--use-fake-ui-for-media-stream",
      "--start-maximized",
      "--kiosk",
      "--enabled",
      "--disable-infobars",
      "--autoplay-policy=no-user-gesture-required",
      "--ignore-certificate-errors"
    ]
  }
  stats {
    enable-stats-d = true
  }
  webhook {
    // A list of subscribers interested in receiving webhook events
    subscribers = []
  }
  jwt-info {
    // The path to a .pem file which will be used to sign JWT tokens used in webhook
    // requests.  If not set, no JWT will be added to webhook requests.
    # signing-key-path = "/path/to/key.pem"

    // The kid to use as part of the JWT
    # kid = "key-id"

    // The issuer of the JWT
    # issuer = "issuer"

    // The audience of the JWT
    # audience = "audience"

    // The TTL of each generated JWT.  Can't be less than 10 minutes.
    # ttl = 1 hour
  }
  call-status-checks {
    // If all clients have their audio and video muted and if Jibri does not
    // detect any data stream (audio or video) comming in, it will stop
    // recording after NO_MEDIA_TIMEOUT expires.
    no-media-timeout = 30 seconds

    // If all clients have their audio and video muted, Jibri consideres this
    // as an empty call and stops the recording after ALL_MUTED_TIMEOUT expires.
    all-muted-timeout = 10 minutes

    // When detecting if a call is empty, Jibri takes into consideration for how
    // long the call has been empty already. If it has been empty for more than
    // DEFAULT_CALL_EMPTY_TIMEOUT, it will consider it empty and stop the recording.
    default-call-empty-timeout = 30 seconds
  }
}

i like jitsi
:joy_cat:

@Freddie thanks for this amazing tutorial!
In the section to check password for auth field

grep password /var/lib/prosody/auth*/accounts/jibri.dat
sed -n ‘/control.login/, /}/p’ /etc/jitsi/jibri/config.json | grep password
sed -n ‘/control.login/, /}/p’ /etc/jitsi/jibri/jibri.conf | grep password

I do not have a password field in /var/lib/prosody/auth*/accounts/jibri.dat. I reran the command to register jibri user(prosodyctl register jibri auth.jitsi.example.com jibriauthpass) but still the file is not updating