TUTORIAL: Jibri Overview, Troubleshooting Tips & Tricks - Solve your Jibri Problems, Quickly!

Wait - do you get an error message on recording or it appears to record fine but no file is produced? Because your logs you shared don’t show any errors, so it seems like something else is going on.

There’s no error message/pop-up, not even the “preparing to record the meeting”.

It had java-11-openjdk-amd64 set as default.
I updated it using above instructions to
/usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java.
And, replaced the java in /opt/jitsi/jibri/launch.sh

Now, jitsi-videobridge2.service & jibri.service are failing to start

jibri.service - Jibri Process
     Loaded: loaded (/etc/systemd/system/jibri.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Wed 2022-11-23 06:25:36 UTC; 5min ago
    Process: 482240 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=1/FAILURE)
   Main PID: 482240 (code=exited, status=1/FAILURE)
jitsi-videobridge2.service - Jitsi Videobridge
     Loaded: loaded (/lib/systemd/system/jitsi-videobridge2.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Wed 2022-11-23 06:29:23 UTC; 228ms ago
    Process: 485920 ExecStart=/bin/bash -c exec /usr/share/jitsi-videobridge/jvb.sh ${JVB_OPTS} < /dev/null >> ${LOGFILE} 2>&1>
    Process: 485921 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jitsi-videobridge/jitsi-videobridge.pid (code=exited, >
   Main PID: 485920 (code=exited, status=1/FAILURE)

It works with Java 11, no need to do that downgrade.
If you saw java8 recommendation, it’s probably an old one - I believe for a long time now everything is being tested with java11

Okay, I’ll revert back to 11 then.

Same as before after reverting.