TUTORIAL - How to Install the NEW JIBRI

I can take another one. What are the minimum parameters?

8CPU/8GB if you want to record in 720p
8CPU/16GB if you want to record in 1080p

Only for Jibri 720p which one is possible?
One Jitsi on my parameters works fine.

:point_up:t5:

Thanks for the reply. On Ubuntu 18, everything worked out. Recording and broadcasting is going on, but due to weak resources it ends quickly. Please tell me in which files the resolution and the quality of the recorded files and the quality of the broadcast are configured.

Thanks. That’s what we need.

Please add the parameter to the instruction # vim /etc/jitsi/jibri/jibri.conf

ffmpeg {
    resolution = "1280x720"
    // The audio source that will be used to capture audio on Linux
    audio-source = "alsa"
    // The audio device that will be used to capture audio on Linux
    audio-device = "plug:bsnoop"
  }

The recording works without it, but the file is created without encoding and it cannot be viewed.

There is one problem with the recording that I can’t figure out. After restarting the server, when recording is turned on, it does not show any messages and does not change the status, although recording is going on. It is enough to close the room and the recording stops. In all subsequent created rooms, recording is in normal mode.
Tell me where to look for the problem.

It seems like the initial run of headless Chrome takes time

so many people watching the problem about jibri installation, pelease any guys dispaly the latest jibri installation guaidline

This is actually not true. Recording works fine anyway, but because latest version of Jibri now defaults to 1080p, you need a stronger server to run it. So what you experienced is the result of a server with inadequate specs.

The new server doesn’t have that server anymore 8CPU/16GB 720p
Debian 11 Java 11

Thank you so much :slight_smile: Your hint helped.

@Freddie FWIW : I think you can now remove xserver-xorg-input-void from the misc packages list , but add ruby-hocon

1 Like

Nice to know. I’ll try that out once I get my hands on a free server. :+1:t5:

Hi Freddie ,

Thanks for your advice about my jitsi server, now is running well with the latest version ,

Now , i need your advice , before upgrade jitsi, i already has a jibri server on another machine,

how to connect my old jibri ,to the latest version of jitsi ?
please advice

Thanks n regards,

If it’s still the same domain, do steps 11-18 above then restart all services.

Hi Freddie ,
yes, it’s still same domain,

I’ve try to do from point 11 - 18 , but i have confused at point 14 & 15
because in new jitsi, there’s no sip-commnicator.properties, there’s a jicofo.conf

i try to add the lines on jicofo.conf like below :

Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for

#available options, syntax, and default values.
jicofo {
xmpp: {
client: {
client-proxy: focus.jitsi.mydomain.com
}
trusted-domains: [ “recorder.jitsi.mydomain.com” ]
}
bridge: {
brewery-jid: “JvbBrewery@internal.auth.jitsi.mydomain.com
}
}

jicofo {
authentication: {
enabled: true
type: XMPP
login-url: jitsi.mydomain.com
}
}
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.jitsi.mydomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

but the result ,it’s making an error on my jitsi :

please advice ,

Regards,