TURN with UDP over DTLS

Trying to get Jitsi and turnserver to accept UDP

{ type = "turns", host = "jitmeet.example.com", port = 5349, transport = "udp", secret = true, ttl = 86400, algorithm = "turn" }

but when opening the web console in Chrome it says 5349 over tcp+tls(which works) even if only udp turn is listed under external_services in jvb-config(no tcp listed).

useTurnUdp=true is configured

Does this even work? Or is only type = turn allowed for UDP?

turns is tcp. turn is udp. Everything going out of the browser using webrtc is encrypted.

Thanks! Signaling is still unencrypted right?

Does this mean we should also configure no-dtls in the turnconfig? As dtls is overkill

Anything else on turnserver that is worth configuring in regards to udp?

No, everything is over https.

Hum, I don’t think you should disable that.

These are good defaults that jitsi-meet uses when installed jitsi-meet/turnserver.conf at master · jitsi/jitsi-meet · GitHub
They work for turns and turn. And both are enabled by default
jitsi-meet/prosody.cfg.lua-jvb.example at ac2698f8297d516b0480fa0dbdb2ff274a556030 · jitsi/jitsi-meet · GitHub