TURN server not reducing load on server?

Hey guys,

I’ve setup a coTURN server and integrated it into Jitsi using Prosody etc. When checking webrtc internals everything looks fine as the ICE servers include my coTURN server.

However, during a 1-1 call the IP address is still being shown as my Jitsi server going through port 10,000 via UDP. Colibri stats shows conferences = 1 and p2p_conferences = 0. The CPU load increases on the server too (more so than before I enabled TURN actually).

Normally if I attempt a 1-1 call on my local network, it will show “p2p” and my local IP. Colibri stats shows conferences = 1 and p2p_conferences = 1.

Is this normal? Is there a more comprehensive way to check if TURN is working?

on your jvb machine add iptables rule that blocks traffic from your public address (from where you are testing ) to udp 10000 of the brodge. You will go through turn or there will be no media reaching the bridge. Open 3 tabs, if you see media it should be going through turn if iptables rule is correct.