Turn server configuration (with 2 server)

Hello,

I’ve tried to install jisti and make it work with a coturn server:

Jisti server is on url : visio.xxx.fr
Coturn is on a different server with this url : turn.xxx.fr

I installed cotunr with paquet named : jitsi-meet-turnserver

   # jitsi-meet coturn config. Do not modify this line
use-auth-secret
keep-address-family
static-auth-secret=osnAiNez5AZAXAGd
realm=turn.xxxxxx.fr
cert=/etc/coturn/certs/turn.xxxxxx.fr.fullchain.pem
pkey=/etc/coturn/certs/turn.xxxxxx.fr.privkey.pem
no-multicast-peers
no-cli
no-loopback-peers
no-tcp-relay
no-tcp
listening-port=3478
tls-listening-port=5349
no-tlsv1
no-tlsv1_1

on jisti server

external_service_secret= "osnAiNez5AZAXAGd";
external_services= {
    { type = "stun", host = "turn.xxxx.fr" },
    { type = "turn", host = "turn.xxx.fr", port = 3478},
    { type = "turns", host = "turn.xxx.fr", port = 5349, transport = "tcp" }
}

“external_services”; in module enabled

in js conf :
p2p:
useStunTurn: true,
// The STUN servers that will be used in the peer to peer connections
stunServers: [

        //{ urls: 'stun:visio.xxxxx.fr:3478' },
        { urls: 'stun:meet-jit-si-turnrelay.jitsi.net:443' }
    ]

},
useStunTurn: true,

Honestly I tested the turn server with that Trickle ICE. I’ve a done and I don’t know if it’s good or not.
And in my webrct on chrome :
https://visio.xxxxs.fr/xx, { iceServers: , iceTransportPolicy: all,
If I use a jisti server I’ve that :
https://meet.jit.sixxxxd, { iceServers: [turns:meet-jit-si-turnrelay.jitsi.net:443?transport=tcp], iceTransportPolicy: all,

I found the problem. It’s not work at all with firefox on linux

I purge all my installation and do a fresh install and it’s work well with chromium based worker. Ofc with external_service not turnserver.

I have the same error on firefox on official jisti server.