Turn on lobby feature and “Add a password” feature

Capture

Here's what i have. 

VirtualHost "meet.mydomain.com"
    enabled = true -- Remove this line to enable this host
    authentication = "internal_plain"

    -- authentication = "anonymous"
    -- Properties below are modified by jitsi-meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/meet.mydomain.com.key";
        certificate = "/etc/prosody/certs/meet.mydomain.com.crt";
    }
    av_moderation_component = "avmoderation.meet.mydomain.com"
    speakerstats_component = "speakerstats.meet.mydomain.com"
    conference_duration_component = "conferenceduration.meet.mydomain.com"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "muc_breakout_rooms";
        "av_moderation";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.meet.mydomain.com"
    breakout_rooms_muc = "breakout.meet.mydomain.com"
    main_muc = "conference.meet.mydomain.com"
    --muc_lobby_whitelist = { "recorder.meet.mydomain.com" } -- Here we can whitelist jibri to enter lobby enabled rooms

from the few informations you provided I’ll assume (because your symptoms are characteristic) that you attempted to setup secure domain and missed a step. It’s impossible to guess which, so I’ll just advise you to read again the fine manual and do the 5 (IIRC) things necessary to setup up secure domain. A favourite thing to miss is Jicofo configuration.