Trying to delete all cached datas on Jitsi Meet Electron app


#1

Hi Jitsi team !
We use the electron app for Jitsi (work pretty good!) but we have a problem.
When we uninstall the app, or same, when we build a fresh electron app (with npm install before run dist) and install the very new version on our computer, the application keep all our “rooms history” and also languages traduction from the very first time… It’s like the application keeps somewhere a “cache” of everything, and we don’t know where and how.

We changed traductions on /lang on our Jitsi Meet server, did a npm install and make commands, but nothing changed on the electron app… same if we uninstall it, or create a new one.
This is weird, because normaly it is just an “iframe” of our Jitsi Meet server, where all changes are OK for traduction / languages (we see our changes on the Jitsi Meet welcome page and conferences). But doesn’t reflect in our electron app (example : for the “Leave comments” traduction? We changer for something else. It is all ok on our Jitsi Meet server, but still the same again and again on our electron app).

Could you please tell us how we can do to just “clear” all the past datas, and have the new / fresh ones everytime? (on Windows computers, but also Mac computers). We tried in many ways, but haven’t found any solution to that problem.

Maybe we have to “delete” the node_module folder (and not just launch a “npm install”) to update all in the electron app?

Thanks for your support


#2

Hi !
Do you know how to delete all cached datas on the electron app’s?
All our meeting code stay, same if we delete the application and install it again.
We don’t know where these datas are on our computer. Any idea?


#3

On macOS it’s in ~/Library/Application Support/YOUR_APP_NAME you can delete that and restart, and it will behave as if you just installed it. Note that all your settings will also be gone.


#4

Thanks saghul! On Mac Os seems like OK, but not on windows… impossible to find where are the cached datas


#5

Should be inside %APPDATA%. Maybe inside Romaing.


#6

That’s right! Found it! Perfect, it works :slight_smile: Thanks again saghul!