Troubles in reinstall with existing Letsencrypt cert

Hello,

I am trying to reinstall jitsi-meet on a Debian 10 system using apache2. The first time I had followed the video tutorial and it was very smooth. The installation worked, but it was for a made-up local domain with a snake-oil cert. I then decided to redo it with a true domain and cert. I got a Letsencrypt cert and got https working fine with an empty site, without using jitsy procedures.

I gave the apt-get purge command seen in the quick install guide to remove the first installation. The system could not purge jigasi due to a user name does not exist error (I tried repeating the command as suggested but the error stayed). I continued anyway with apt autoremove and apt -y install jitsi-meet.

At this point it asks me for the hostname, and then it gives me a choice between generating a self-signed certificate or using my own, and I choose the second. Then it asks me for the keys and cert paths. Here I indicate the letsencrypt locations /etc/letsencrypt/live/<host>/{privkey.pem,fullchain.pem}. Then the installer concludes after writing out a note that I need to run /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh .

But this is puzzling, since this procedure seems to run cerbot again and prompts me with the email for the ACME agreement - I already went through this and I already have the cert installed and tested, and I can use https without problems.

What is the proper way to do a reinstall with an existing valid Letsencrypt cert? I made another test after putting symbolic links in /etc/ssl pointing to the Letsencrypy key and cert, but it did not seem to help.

Thanks

If you already have a valid LE cert, just don’t run the jitsi LE script. It’s a prompt which appears in all setup routines, even if you’re doing an upgrade over an installation which already has an LE cert in place.

Thank you, indeed it worked, recognizing that the certificate exists. It was just a bit confusing to me.