Trouble updating meet to newest version

I am try to update my Jitsi meet server on Debian, so I run this cmd:
sudo apt install jitsi-meet

but It doesn’t update, and I get this message:

jitsi-meet is already the newest version (2.0.5390-3).
and the interface shows up as the old one

Did you update the archive key?

Thanks!