Trouble setting up ports with nginx and docker

Having trouble with docker jitsi with nginx setup. I’m trying to get the docker’s local ports to all be in the 6000s because I have other things running which are using the other ports.
Here are the things I have changed to attempt to get this working:

docker-compose.yml

web:
    ports:
        - '${HTTP_PORT}:6080'
        - '${HTTPS_PORT}:6443'
prosody:
        expose:
            - '6222'
            - '6347'
            - '6280'

in the .env file:

HTTP_PORT=6080
HTTPS_PORT=6443

/etc/nginx/conf.d/jitsi.conf

server { 
    server_name jitsi.domain.com;
 
    location / { 
        proxy_pass http://localhost:6080/;
        proxy_set_header Host $host;
    }    
}

I don’t have ssl setup at the moment, I was thinking i should get that setup after getting the webpage to showup at all. Currently it just shows the default thanks for installing nginx webpage

edit: actually it gives 502 with the above settings

I’m afraid we assume the Prosody ports will be the standard ones. 5222, 5347 and 5280 are standard XMPP ports, you should not run other things in them.