Transcription in Jitsi Meet: CC button not quite working, transcriber not joining hidden

I think the request Transcriber has been interrupted. And after that they request again, more than one timejigasi-log.txt (29.3 KB)

You need to find out why you get the error:

Jicofo 2019-10-01 16:10:27.625 INFO: [534] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2019-10-01 16:10:32.631 WARNING: [534] org.jitsi.jicofo.jigasi.TranscriberManager.log() failed to invite transcriber. Got error: null

You can add in /etc/jitsi/jicofo/config in JAVA_SYS_PROPS:
-Dsmack.debugEnabled=true -Dsmack.debuggerClass=org.jivesoftware.smack.debugger.ConsoleDebugger and you will see the xmpp messages that are exchanged in the logs and you can see what is the problem and fix it.

1 Like

If you do not mind you can take a look? Thanks
Jicofo-log-add.txt (89.9 KB)Jicofo-log-adding.txt (67.6 KB)

<iq id='gWB2J-1565' type='error' to='focus@auth.vcrxdev10.topica.vn/focus629283599723538' from='jigasibreweryroom@internal.auth.vcrxdev10.topica.vn/jitsi-edntg3'><error xmlns='http://jabber.org/protocol/httpbind' type='cancel'><internal-server-error xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/><text xmlns='urn:ietf:params:xml:ns:xmpp-stanzas' xml:lang='en'>Fail to join muc!</text></error></iq>

Hi @damencho

I have a problem when i run jigasi. Can you share with me the way to fix this. This is my log :

2019-10-15 09:45:06.446 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.466 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.486 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.506 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.526 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.547 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.566 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.586 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.606 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant 2019-10-15 09:45:06.626 WARNING: [143] org.jitsi.jigasi.transcription.Transcriber.log() Reading from SSRC 1009569864 while it is not known as a participant

Thank you

1 Like

Hi, I am having the same issue, did you manage to solve it ?
Thanks.

1 Like

Hi,

You can try enabling adding hiddenDomain:“auth.yourdomain” in your config.js. If not it might be hiddenDomain:“recorder.yourdomain”.

Regards,
Anthony

What does any of that mean?

1 Like

We have the same issue.

Someone else opened a new threat for it:

Hi @voxter, were you able to compile the notes for Jigasi installation. I am unable to get through the steps yet, and would really benefit from your notes on connecting the various components together and getting the transcribe functionality working

@damencho
I have configured transcription and it’s working only for host. Could you tell me How to enable it for all the participants, so they can see the same transcription just like Host.

Thank you

I think I fixed the code in unstable for that but tested it today and it is still not working, I will revisit in few weeks and fix it before the next stable release, hopefully.

Actually it should work with latest unstable, you can try that.