Transcribe not working

Hello,

I have installed latest version of jitsi-meet, Jigasi on Ubuntu 18.
I can see the cc option on menu, and when I click on CC button, the transcriber is also joining the conference.

But I can’t see the transcription on the screen.
I have updated the property in interface-config.xml DISABLE_TRANSCRIPTION_SUBTITLES: false.

Did you make config changes as suggested in GitHub - jitsi/jigasi: Jigasi: a server-side application acting as a gateway to Jitsi Meet conferences. Currently allows regular SIP clients to join meetings and provides transcription capabilities.?

Also do you have proper Google(assuming) credentials and configured the location in sip communicator properties?

If yes and still not working, attach Jigasi and jicofo logs…

jicofo.log (23.1 KB)
jigasi.log (51.7 KB)
jvb.log (50.4 KB)
Please find the attached requested log files.

Try using java8 for jigasi, does that change anything?

jicofo.log (9.4 KB)
jigasi.log (44.7 KB)
jvb.log (7.5 KB)
Tried with java 8, with same set of installation instructions. Now the transcriber user is not joining the conference

In your jigasi config you have: org.jitsi.impl.configuration.ConfigurationServiceImpl.log() org.jitsi.jigasi.ENABLE_TRANSCRIPTION=false

Fix that and try again.

jicofo1.log (34.7 KB)

jicofo.log (5.6 KB)
jigasi.log (186.1 KB)
jvb.log (339.1 KB)
Same issues. Attached the logs.

jicofo.log (13.2 KB)
jigasi.log (66.0 KB)
jvb.log (314.8 KB)
Previous attachments were of different server, Please use this logs.

Your jigasi cannot establish https connection to ram2.eastus.cloudapp.azure.com.

I have opened the both the ports 443 and 80 in Azure. Is there anything else I can do to resolve the isue

Do you still see the errors?

Yes. I still have same issue. I can see CC button, subscriber in not joining.

Check if the first point makes any difference… Unable to invite transcriber due to no Jigasi instances being available - #72 by Prashanth

jicofo.log (15.2 KB)
jigasi.log (96.8 KB)
jvb.log (14.4 KB)
Doesn’t make much difference. Attached the logs

Try uncommenting:

And jigasi/sip-communicator.properties at 65ef768f1637f276202f20b6e4a9d44e822173e8 · jitsi/jigasi · GitHub
Does that make a change?

No luck.
jicofo.log (32.6 KB)
jigasi.log (197.2 KB)
jvb.log (52.4 KB)

Also, I am haven’t created any users. I am using anonymous authentication only for both Jitsi and Jigasi.

Why then jigasi is trying to authenticate?

I have made below changes as per Prasanth suggestion
OK. For the reference of other users, we did two changes, after quick install:

  1. commented out net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName} (jigasi/sipcommunicator)
  2. Configured hidden domain
    org.jitsi.jigasi.xmpp.acc.USER_ID=hiddenuser@myhiddendomain.com
    org.jitsi.jigasi.xmpp.acc.PASS=hiddenpassword

May be this causing the authentication part

You have created this user?