TOOLBAR_BUTTONS override is not working

Hi all, I have the next problem. I would like to embed jitsi on my WebSite but I only want to have microphone, camera and tileview as options. I’m using the next code but it’s not working. I already know there is a filmStripOnly but using that I won’t be able to get tileview button.

<head>
    <meta charset="utf-8">
    <meta http-equiv="content-type" content="text/html;charset=utf-8">
</head>
<body>
    <script src="https://meet.jit.si/external_api.js"></script>
    <script>
        var domain = "meet.jit.si";
        var options = {
            roomName: "AnyName",
            width: 600,
            height: 600,
            interfaceConfigOverwrite: {
              LANG_DETECTION: true,
              TOOLBAR_BUTTONS: ['microphone', 'camera', 'tileview'],
              filmStripOnly: false,
              DEFAULT_BACKGROUND: '#4dbdea'
            }
        }
        var api = new JitsiMeetExternalAPI(domain, options);
    </script>
</body>

Do am I forgetting anything?

I think I’ve found the answer by myself, sorry [No subtitles].

[edit]
Well, it’s not working yet. If anyone has any idea, I’d appreciate it.

Experiencing the same issue as of today. It used to work well, but today suddenly buttons that were hidden earlier started to be displayed. In fact, all the controls are displayed. Without any changes in the code on our side (TOOLBAR_BUTTONS: [‘settings’, ‘tileview’, ‘info’ ]).

Were there any changes released over the weekend that could have caused breaking this configuration?

Yes, I believe we broke this the last few days. I’m taking a look now.

Fix here: https://github.com/jitsi/jitsi-meet/pull/5104 please follow that PR for updates. Sorry for the trouble.

1 Like

Hi @saghul, a quick question only for information, not pressure. After the commit get merge, what is the process or how many time it can take to be reflected on the jitsi server?

Days or weeks, it depends… I think we have one planned soon.