Token Setup Issues

Is anyone else having issues with setting up JWT auth on Jitsi? I’ve done 4 clean installs and I keep getting the same result, after following: https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md my prosody log just gives me:

> May 14 17:54:35 c2s55cec9eb31a0	error	Traceback[c2s]: /usr/share/lua/5.1/prosody/util/cache.lua:66: table index is nil
> stack traceback:
> 	/usr/share/lua/5.1/prosody/util/cache.lua:66: in function 'set'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:185: in function 'track_room'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:213: in function </usr/lib/prosody/modules/muc/mod_muc.lua:200>
> 	(tail call): ?
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:446: in function '?'
> 	/usr/share/lua/5.1/prosody/util/events.lua:79: in function </usr/share/lua/5.1/prosody/util/events.lua:75>
> 	(tail call): ?
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:188: in function 'core_post_stanza'
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:128: in function 'core_process_stanza'
> 	/usr/lib/prosody/modules/mod_c2s.lua:294: in function 'func'
> 	/usr/share/lua/5.1/prosody/util/async.lua:127: in function </usr/share/lua/5.1/prosody/util/async.lua:125>
> May 14 17:54:40 c2s55cec9eb31a0	error	Traceback[c2s]: /usr/share/lua/5.1/prosody/util/cache.lua:66: table index is nil
> stack traceback:
> 	/usr/share/lua/5.1/prosody/util/cache.lua:66: in function 'set'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:185: in function 'track_room'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:213: in function </usr/lib/prosody/modules/muc/mod_muc.lua:200>
> 	(tail call): ?
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:446: in function '?'
> 	/usr/share/lua/5.1/prosody/util/events.lua:79: in function </usr/share/lua/5.1/prosody/util/events.lua:75>
> 	(tail call): ?
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:188: in function 'core_post_stanza'
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:128: in function 'core_process_stanza'
> 	/usr/lib/prosody/modules/mod_c2s.lua:294: in function 'func'
> 	/usr/share/lua/5.1/prosody/util/async.lua:127: in function </usr/share/lua/5.1/prosody/util/async.lua:125>
> May 14 17:54:45 c2s55cec9eb31a0	error	Traceback[c2s]: /usr/share/lua/5.1/prosody/util/cache.lua:66: table index is nil
> stack traceback:
> 	/usr/share/lua/5.1/prosody/util/cache.lua:66: in function 'set'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:185: in function 'track_room'
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:213: in function </usr/lib/prosody/modules/muc/mod_muc.lua:200>
> 	(tail call): ?
> 	/usr/lib/prosody/modules/muc/mod_muc.lua:446: in function '?'
> 	/usr/share/lua/5.1/prosody/util/events.lua:79: in function </usr/share/lua/5.1/prosody/util/events.lua:75>
> 	(tail call): ?
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:188: in function 'core_post_stanza'
> 	/usr/share/lua/5.1/prosody/core/stanza_router.lua:128: in function 'core_process_stanza'
> 	/usr/lib/prosody/modules/mod_c2s.lua:294: in function 'func'
> 	/usr/share/lua/5.1/prosody/util/async.lua:127: in function </usr/share/lua/5.1/prosody/util/async.lua:125>

I’m setting everything up on GCP using Ubuntu 18.04, but my outcome is always the same. The front-end gives me: Strophe: Server did not yet offer a supported authentication mechanism. Sending a blank poll request.

For prosody, I’m using: prosody-trunk_1nightly1275-1~bionic_amd64.deb

Anyone else having this issue?

Hum, what about 0.11, have you tried it, is there a reason for the trunk and not using stable?

I’m following the guide provided by Jitsi, which I’m finding is not correct. it says…

“You can download latest prosody-trunk packages from here. Then install it with the following command…”

Just did a fresh build with the 18.04 on GCP with prosody from their repo (0.11.5-1~bionic6) and no dice. For a product that is so extremely easy to setup with anonymous access it seems to be difficult to setup JWT auth, which is what I would believe most developers would like to use. Are they any know working guides that someone can point me to? I’ve spent more then a day on the guide provided by the Jitsi team, but I’ve come to the conclusion that that just doesn’t work on Ubuntu 18.04.

Hi. I was having same problems. I followed this guide after a fresh install of Ubuntu 18.04 and tokens are now working ok:

https://pastebin.com/eTSnENqJ

Hope this helps you.

Thanks, I’ll give it a go now…