Token authentication does not work on Debian 10


we have successfully installed jitsi on a Debian 10.
Now we have been trying for 5 days to change the authentication to tokens. And have done everything according to instructions. But it just won’t work.

We have found out that the module “mod_token_verification.lua” is started, but it remains at the line ‘local token_util = module:require “token/util”.new(parentCtx);’.

Did anyone with Debian 10 and the current stable packages make token authentication work and how?
Apart from the settings in /etc/prosody/conf.d/, do you need to make settings for token authentication elsewhere?

We are really grateful for any help and apologize for the bad English.

I created the follow doc to install Jitsi Meet (with new JVB2) and Jitsi-meet-tokens in ubuntu 18.04, it’s working perfectly.

Jitsi Installation Doc

Thanks for the answer and the documentation.
With the scripts I managed to get the token authentication up and running on Debian 10 with a small adjustment.

I had to use Debian 9 libssl1.0-dev.

wget &&
dpkg -i libssl1.0-dev_1.0.2u-1~deb9u1_amd64.deb

Hi it-flx,

Could you said me how-to install token on Debian 10?


Hello Sergio_Ruiz
I am in the process of doing the installation cleanly and documenting it again.
The order as described in the documentation by Mike Christian is important. Since it is not possible to install libssl1.0-dev from the repositories, these must first be downloaded from Debian and installed.
Otherwise the scripts went through cleanly.

I hope that helps first. When I have finished my documentation, I will make it available.

English is my mother tongue, only the Google translator can help.

Any updates on the documentation?

Is this still the case when using the latest stable packages?

Yes, I wasn’t able to setup Jitsi with JWT on Debian (Jitsi without JWT or Jitsi with User-Auth “internal_hased” worked fine on Debian). I tried for 12h everything :sweat_smile: I did the setup steps of the documentations multiple times (Docs/Jitsi Meet Install (Ubuntu 18.04).md at master · christiancuri/Docs · GitHub didn’t worked and lib-jitsi-meet/ at master · jitsi/lib-jitsi-meet · GitHub as well). I ran in serval errors. At the end of the day I switched from Debian to Ubuntu and everything worked.

The libssl1.0-dev is not in the stable Debian repo, It’s needed to add the old stable repo to sources.list or manually installed the package.

The stable repo comes with libssl-dev which is compiled against libssl1.1

edit: I checked again. lua_cjson can be compiled without adding the old repo, no need to add the libssl1.0-dev package now

We did an update of the jwt deps so we can migrate docker to latest debian.

If the Docker installation handles Jibri too, openjdk-8-jre is not in the official Debian repo.
nvidia-openjdk-8-jre which is in the official repo, may be an alternative

Docker uses java11