Toggle Button camera NOT APPEARING glitch config.js file

Hi community,

I have a self hosted server… I have found this odd glitch… If i comment in config.js all the ToolButton area where all the buttons are like this

/*toolbarButtons: [
‘microphone’, ‘camera’, ‘closedcaptions’, ‘desktop’, ‘embedmeeting’, ‘fullscreen’,
‘fodeviceselection’, ‘hangup’, ‘profile’, ‘chat’, ‘recording’,
‘livestreaming’, ‘etherpad’, ‘sharedvideo’, ‘shareaudio’, ‘settings’, ‘raisehand’,
‘videoquality’, ‘filmstrip’, ‘invite’, ‘feedback’, ‘stats’, ‘shortcuts’,
‘tileview’, ‘select-background’,‘download’, ‘help’, ‘mute-everyone’, ‘mute-video-everyone’ , ‘security’
],
*/

the TOGGLE CAMERA button in IOS browser (i tested safari and opera) appears without problem in the More options area… but if i use the toolButtons to for example just disappear the recording like this :slight_smile:

toolbarButtons: [
‘microphone’, ‘camera’, ‘closedcaptions’, ‘desktop’, ‘embedmeeting’, ‘fullscreen’,
‘fodeviceselection’, ‘hangup’, ‘profile’, ‘chat’, /‘recording’,*/
‘livestreaming’, ‘etherpad’, ‘sharedvideo’, ‘shareaudio’, ‘settings’, ‘raisehand’,
‘videoquality’, ‘filmstrip’, ‘invite’, ‘feedback’, ‘stats’, ‘shortcuts’,
‘tileview’, ‘select-background’,‘download’, ‘help’, ‘mute-everyone’, ‘mute-video-everyone’ , ‘security’
],

TOGGLE CAMERA button does not appear.

Does anyone has experienced this?

Is there a label or button name am i missing?

Thanks in advance

Looks like you are missing a * after the first forward slash. Can you try again after fixing it ?

Hi,

Thank you for your answer i did , i actually only commented all the buttons like i post :slight_smile:
/*toolbarButtons: [
‘microphone’, ‘camera’, ‘closedcaptions’, ‘desktop’, ‘embedmeeting’, ‘fullscreen’,
‘fodeviceselection’, ‘hangup’, ‘profile’, ‘chat’, ‘recording’,
‘livestreaming’, ‘etherpad’, ‘sharedvideo’, ‘shareaudio’, ‘settings’, ‘raisehand’,
‘videoquality’, ‘filmstrip’, ‘invite’, ‘feedback’, ‘stats’, ‘shortcuts’,
‘tileview’, ‘select-background’,‘download’, ‘help’, ‘mute-everyone’, ‘mute-video-everyone’ , ‘security’
],
*/

the toggle button apears… if i use the toolbar

toolbarButtons: [
‘microphone’, ‘camera’, ‘closedcaptions’, ‘desktop’, ‘embedmeeting’, ‘fullscreen’,
‘fodeviceselection’, ‘hangup’, ‘profile’, ‘chat’, ‘recording’,
‘livestreaming’, ‘etherpad’, ‘sharedvideo’, ‘shareaudio’, ‘settings’, ‘raisehand’,
‘videoquality’, ‘filmstrip’, ‘invite’, ‘feedback’, ‘stats’, ‘shortcuts’,
‘tileview’, ‘select-background’,‘download’, ‘help’, ‘mute-everyone’, ‘mute-video-everyone’ , ‘security’
],

with all the buttons active same thing… no toggle button appears.

Thanks !!

is not your button ‘appearing’ (well, in a way) in the toolbar ? I think I see arrows in the toolbar in your screenshot ? It’s documented that it’s not possible to control if buttons appear in the ‘More…’ menu.

Hi,

That’s the thing it just disappears… If i “comment” all the buttons, the fail back documented behavior is as you said all the buttons appears, including the toggle camera button… but even just putting the TOOLBARBUTTONS area without any change (just uncomment it from the original file) the toggle camera button disappears.

What happens if you click on the arrow I highlighted ? Do you see more icons ?

toolbarjitsi

the blue arrows are from safari if i click them i go out from the jitsi room.

That’s very strange that you have different icons on Safari and you have 2 icons to exit the room while on other devices there is only one and it looks like an exit icon; however not having any Apple device myself I see no way to try to help you further.

Can you add 'toggle-camera' to the list of the toolbarButtons and check again ?

Looks like our config.js needs to be updated, this button was recently added to mobile browsers and toolbarButtons: in config.js wasn’t updated. I will fix this. Thanks for reporting this issue.

2 Likes

Thank you !

1 Like