Timeout When Jibri Start Recording

Hi im new jitsi user , when i click “start recording” ,selenium process timeout to my jitsi url . This is part of log that show if it’s timeout

2020-02-27 14:14:38.437 FINE: [45] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://azure-video-api.burhanyusuf.dev/5e572cc4ae389#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false
2020-02-27 14:15:09.149 SEVERE: [45] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load

Anyhelp?

Can you reproduce this consistently? I can acess it fine, maybe our timeout is too low @bbaldino ?

From my server , i tested with wget , curl, etc, its success only 1-2 sec .
Maybe it’s from selenium or?

What are the resources available for jibri, like memory? Are you running with java8?

Use Azure VM Standard DS1 v2 (1 vcpus, 3.5 GiB memory) , ubuntu OS.
Output from java --version :

openjdk 11.0.6 2020-01-14
OpenJDK Runtime Environment (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1)
OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1, mixed mode)

Use java8 and maybe increase memory … try with 3.5 GB but maybe that is not enough for running chrome and ffmpeg and the rest of the services at the same time …

I resize vm to 2vcpu dan 7GB memory and change the java version to 8, but still timeout.

Wildly guess, its from chromedriver and chromebrowser , i tested chromedriver example code with python , it’s show error :

 Traceback (most recent call last):
  File "chromedriver.py", line 4, in <module>
    driver = webdriver.Chrome("/usr/local/bin/chromedriver")  # Optional argument, if not specified will search path.
  File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/chrome/webdriver.py", line 81, in __init__
    desired_capabilities=desired_capabilities)
  File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 157, in __init__
    self.start_session(capabilities, browser_profile)
  File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 252, in start_session
    response = self.execute(Command.NEW_SESSION, parameters)
  File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 321, in execute
    self.error_handler.check_response(response)
  File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/errorhandler.py", line 242, in check_response
    raise exception_class(message, screen, stacktrace)
selenium.common.exceptions.WebDriverException: Message: unknown error: Chrome failed to start: exited abnormally.
  (unknown error: DevToolsActivePort file doesn't exist)
  (The process started from chrome location /usr/bin/google-chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)

And this is browser log from jibri folder :

https://gist.githubusercontent.com/hanzkid/63113f10111cd2231304bdd6e7fe45a2/raw/b9be9fae53e25c55c2e1403bcbf68883ffbab270/Browser%20Log

`

Solved with this topic, sorry just forget about jwt :
[SOLVED] Jibri with JWT token enabled Jitsi.