Time Lag for Joining Meeting and Sending Message

Okay so I have set up jitsi meet on my own server in azure vm (2vcpus, 4GB ram) using this guide Self-Hosted and it works fine but I have an issue… it takes about 1 full minute (60 SECONDS) for a user to join or start a meeting… also messaging is not instantaneous most times it takes a minute for the message to send… I want to know if there is some config or something wrong
I want to be able to join and start a meeting quickly like in max 4 seconds no lag and send messages instantaneously
mind you I only have 2 users and all my conferences will be between 2 users
@damencho , any help with this issue ?

Bawo ni? :smiley: Welcome to the forum.

What version of prosody are you using?

haha mo wa pa, thank you
I am not sure what version of prosody
I just set up following the self-hosted guide
how can I check what version ?

Run the following command in your terminal:

dpkg -s prosody | grep Version

the result of that command is : 0.10.0-1build1

`

Ah, yeah that could be your problem right there. And you used the Self hosted guide, you said? That’s pretty unusual - right now, it should be installing the latest version of prosody for you.

Okay, you have two options - you can either:

  1. Try to upgrade prosody to the latest available version
  2. Start over, but this time first install the latest version of prosody before going through Jitsi installation

If you’re relatively new to the environment, option #2 might be better for you. But either works fine. If you want to go with option 1, check out this thread -[How to] How do I update Prosody?

Thank you I think I will start over
And yes i did use the self-host guide I didn’t change anything followed it completely
How do I install the latest version of prosody first?

Run the following commands:

echo 'deb https://packages.prosody.im/debian focal main' | sudo tee /etc/apt/sources.list.d/prosody.list

wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -

sudo apt update

sudo apt install prosody

That should get you the latest version of prosody.

Oshe gan… I will do that now let me start over

updated same issue

it even got worse because now it reconnects when someone tries to join

This is weird. What distro are you running?

sorry for the late reply… you are right it is strange
2 things were my problem my distro the distro I used that was working but having that issue was this Azure Jitsi
and when I ran it on a normal ubuntu 18.4 LTS i forgot to install gnup2 and jdk 11 (i installed jdk 8 ) and I didnt open the necessary ports
I did a fresh install and used JDK 11 installed gnup2 and it worked fine right of the bat
I would NOT advice anyone to use install jitsi on this distro in azure market place Azure Jitsi

also no one should follow this guide Jitsi on azure,gcp,aws
the article is oudated and their distros not updated and even if you update something is wrong with their config and your jitsi wont work