Tileview users' video don't work if requestedAudio = false

Hi there,
First of want to say thanks so much for the awesome software it’s done so much for us!

We’ve slightly modified the Jitsi FE so that certain users start muted + video disabled. We’ve used the config via API on iframe, however it still prompts for user mic which we don’t want. I found in conference.js of the react app that there’s a variable requestedAudio = true. I’ve conditionally set this to “false” which seems to only prompt them for mic after unmuting(which is what we need), but now those users don’t see other videos in tileview (Only black screens). Everything else works fine.

On the console the error is

  • play() failed because the user didn’t interact with the document first
  • Failed to create local tracks

Is there a way to force user interaction to prevent this or another suggestion perhaps? I’ve tried looking through the code, but can’t figure out how to trigger this interaction to allow the video streams to come through.
By the way I’ve been testing on Chrome. This is traditionally a Chrome error that usually gets solved on video elements by setting muted=“true”, but I see the injected video element does get those values.

Looking forward to a reply.

Yep, this is the prejoin screen.

Hey, ah yes thank you that solves it