Tile view - tile size/ratio

Since the latest upgrade of Jitsi, the tile view is a bit messed up for me.
While using Jitsi I always have the browser window reduced to take the right 1/3 of the screen, while the remaining 2/3 of the screen are taken by the presentation software that I share with my audience. This way, I can work on the presentation software, while at the same time see my audience, check if they raise their hands and see if messages arrive.

Since the implementation of the new jitsi version, the tiles do not proportionately reduce in size and I need to scroll to see some of the participants. Also, the ratio of the tiles is such that the participants’ video is cropped and not sized to fit inside the tiles.

What can I do about it? Can I somehow manually determine either the size of the ratio of the tiles or at least force the Jitsi interface to resize within the consraints of the browser window and not need scroll bars?
Thank you

Can you share screenshots? Perhaps I’m missing what you’re describing, but my experience has been that the tiles resize with a change in window size. Is this on meet.jit.si or do you host your own server?

So far I understand, I’m having the same issue like altiport mentioned above: The new tile view is cropping the video image. In most cases I need a tile view of two participants, but seeing the full video image is important.

Here old and new tile view in comparison:

comparison

Is there a way to get back old behavior and turn off the cropping in tile view?

For any feedback many thanks in advance
Ravelli

For those who are still looking for a solution -

// If true, the tiles will be displayed contained within the available space rather than enlarged to cover it.
// disableTileEnlargement: true,

1 Like

Which file is this setting in? Thanks

/etc/jitsi/meet/your.domain-config.js

This specific setting is not already in that file, so that I can un-comment it . How and where do I add it?
Thanks (and apologies for the simplicity of my query)

You should be able to add it to the file (don’t forget the trailing comma).

Did you upgrade from an older version of Jitsi? I’d expect that commented out entry to be there if it were a fresh install of a recent version.

The installation is almost two years old and I’m not repeating it as it was a pain to set up the token part. The lines do not exist in the config file so as to comment them out. I have been trying to copy the above lines in the config file but it is not working. Maybe it needs some { } characters before and after? Or maybe it needs to be placed in a speific location within the file?

Thanks

Use this as a reference to determine where to place the config:

Cheers! Appreciate your help

Right now I am using meet.jit.si, and in tile mode the video is cropped, not scaled, as mentioned above. But since I’m using meet.jit.si, I don’t have any config files in /etc. Is there anything that I can do in that circumstance? It is a bit of a show-stopper.

Thanks.

You should still be able to pass in that config var as a URL param, for example https://meet.jit.si/SomeRoomName761253#config.disableTileEnlargement=true.

If you use the IFrame API to access meet.jit.si, that same config can be passed in the configOverwrite option.

Shawn, thanks 1E6! I’m a jitsi n00b and didn’t know that you could stick in parameters there. It is working fine right now.

Is all this documented somewhere? If someone could point me to this part of the documentation, I will not need to ask similar questions again.

Thanks Freddie, very helpful.