Tile view in meet.jit.si is showing only four (4) participants

Both at my video conference on Saturday and today during TheCall, I was only able to see four (4) participants at a time (I could scroll down to see the other participants). My laptop has a screen resolution of 1366x768. The problem occurred even in full-screen mode in Firefox in Debian Buster: firefox-esr 78.15.0esr-1~deb10u1.

Is there a way to dynamically vary the number of participants shown in tile view?

In most of my events, seeing all participants at once is helpful because my events tend to be interactive, so the speaker rapidly changes and cycles through all participants. It is helpful to see if someone wants to jump in who does not have the social assertiveness to jump in without help from a facilitator.

So how can I see all participants at once in tile view?

I don’t experience this behavior on Firefox 92. I’m able to see 25 tiles on screen as expected and the remaining tiles when I scroll.

I’m pretty certain there’s no configurable option for this. But I also think it won’t be the best idea to make it configurable because of the strain on client resources with increasing number of tiles.

It sounds like the restriction on visible thumbnails might be something specific to your machine. I’d start checking from there.

This problem persists in 78.15.0esr (64-bit) in the Debian Buster 78.15.0esr-1~deb10u1

I have two systems with the same version of Firefox. My system with a 1920x1080 resolution works fine. My laptop has a resolution of 1366x768. I’ve used that laptop with Jitsi for nearly a year. The problem began during November. Before November I was able to see a full screen of participants. But since some time in November, I only see four participants in tile view and I have to scroll to see others.

It is a Jitsi bug dealing with the unusual screen resolution of this laptop. Here are the first three lines of xrandr -q:
Screen 0: minimum 320 x 200, current 1366 x 1568, maximum 8192 x 8192
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
1366x768 59.97*+

I was frustrated enough with this issue that I decided it was time to upgrade my laptop from Debian 10 to Debian 11 (Bullseye). So now the version of firefox is the Debian package 78.15.0esr-1~deb11u1. New 5.10 kernel. New X11 stack. I even upgraded my microcode to fix a bug Debian was reporting with my CPU/GPU Intel integrated chip.

The problem recurs: since sometime after November 2nd (when tile view showed many participants), I am unable to see more than 4 participants in tile view without scrolling.

I suspect the bug is due to the odd 1366x768 screen dimensions of this laptop. I reported the xrandr output before the upgrade, but did not check if it changed since the upgrade.

I plan to boot the laptop to join the community call on Monday to see if the team can offer some suggestions. Talk to you then.

I believe the bug was introduced on meet.jit.si between November 3rd and November 9th (though I’m not 100% sure). I’m sure the problem had happened by November 27th, but I have a memory of the problem on November 9th.

In Bullseye, my firefox version is 91.4.1esr (64-bit). Debian package: 91.4.1est-1~deb11u1. Confirmed during today’s community call.

Problem does NOT happen on chromium. Never happened before 9 Nov 2021 (I’ve been using Jitsi for a year and half or so). Have happened every time since 9 Nov both before and after upgrade from Debian 10 to Debian 11.

Hi CJ, can you please check what width/height Firefox and Chrome are reporting on the Linux laptop experiencing the issue? You should be able to do this by typing window.innerHeight and window.innerWidth on the browser developer console.


Last night I booted the laptop. The values change depending on screen size and placement of the developer console:

When just a large window (not full screen):
When in full screen with the console docked on the bottom:
When in full screen with the console docked to the right

I believe the bug was introduced on meet.jit.si between November 3rd and November 9th

Sounds plausible to me. Till yesterday I have been using a few months old version of Jitsi without encountering this issue. Since then I updated to 2.0.6726-1 (meet, on Debian Buster). I tested on 1280x1024 display. When I resize the window to under approx. 1000 pixel wide, only 4 tiles are visible at a time. Before that, the tiles simply got smaller, which makes - to my opinion - more sense.

Are these values for Firefox ? Can you please check what values Chrome is reporting on the same machine ? The reported height (245) is falling below the threshold set for 5x5 tiles.

In firefox, if I shrink the console small, not full screen, I get:
When I switch to full screen, I get
In chromium, not full screen, I get
In chromium, full screen, I get

It seems Firefox makes available fewer pixels than Chromium.

But there is plenty of screen real estate available to see more than 2x2 tiles.

Yes, that is why you see the issue on Firefox but not on Chrome. We have made some more adjustments in our responsive-ui code to better adapt to the changing height. Do you still see only 2x2 tiles on meet.jit.si now ?

It appears that the fixes have not landed on meet.jit.si yet. I will update here once the fix lands so that you can verify if your issue is fixed.

Jaya, These two screenshots were taken in full screen mode (I see even less when I haven’t put Firefox in full screen mode which is 1366 x 1568) during today’s community call.

Thanks, Jaya.

Hey @cjfsyntropy , can you try to enable the disableTileEnlargement config? (just set it to true)

Robert, I’m using meet.jit.si not a self-hosted instance. But maybe this TileEnlargement is just an feature not documented at User Guide (advanced) · Jitsi Meet Handbook

Hmm, I don’t understand how to enable config items from that page nor disableTileEnlargement. Do I use config:about in Firefox and just create new config elements? Is there a guide for that? I don’t have experience tweaking these config options.

yes, that’s the case.
that would give you something like:


complete list is here (but there is no explanation):

jitsi-meet/configWhitelist.js at master · jitsi/jitsi-meet · GitHub

Yes, setting TileEnlargement fixes tile view on my 1366x768 laptop. That workaround will save me if Chromium crashes or somesuch. I also look forward to testing the patches that Jaya said are working their way to meet.jit.si.

The changes that Jaya mentioned have been deployed on meet.jit.si a few hours ago.