Tile View changed to show cameras AND screenshares

About a year ago, when we had four participants all sharing their screens, we would have four tiles in the Tile View with the shared screens. This was very convenient.

Now, we have eight tiles, which is four shared screens and four local cameras. This is decidedly less convenient because now the shared screens are too small to read. Turning off our local cameras doesn’t work, because it just means that four of the eight tiles are giant letter avatars.

Is there a way to get the old behavior back?

You can do it 2 ways:

  1. Not recommended: Disable multi-stream. Turn all of these to false: jitsi-meet/config.js at 68f79e52e7d3341e98411df402fb504bb4b612bc · jitsi/jitsi-meet · GitHub – Note that this will be the only available mode int he future.

  2. Use multi-pinning on stage view. Go to Settings > More:

Select the number of participants in the main stage to 4 (in your case). Pin the 4 screen-shares.

Thanks for that @saghul !

However, “pin to stage” only appears as an option when nobody is screensharing, and in any case there seems to be no way to “pin the screen-shares” as you advise. Am I missing something in the user interface? (I even tried the beta public instance.)

@jallamsetty do we not allow that?!

I think pinning behavior on stage filmstrip has been changed few times and @robertpin is the best person to answer this question.

Pinning was done before multi-stream, so it doesn’t support pinning screenshares. We just merged a commit in master to allow this through the API, but the UI does not support it yet. fix(iframeAPI): pinParticipant & setLargeVideo · jitsi/jitsi-meet@49bcf5c · GitHub