The video connection does not work from the outside!


#1

Hi, I deployed a meet-jitsi server on ubuntu 18.04 following this howto :


Everything works in Locale (same network) but no video-audio connection from the outside !!! While there is the message of the connection of such user. Thanks for your help.
Merci.

Moula.


#2

Even i am facing the same problem!
Attaching the error log in my case :
(TIME) index.html loaded: 396.1999999883119
Logger.js:125 [modules/browser/BrowserCapabilities.js] : This appears to be chrome, ver: 71.0
LocalStatsCollector.js:22 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
(anonymous) @ LocalStatsCollector.js:22
Logger.js:125 [react/index.web.js] <HTMLDocument.>: (TIME) document ready: 2558.599999989383
Logger.js:125 [react/features/base/storage/PersistenceRegistry.js] <e.value>: redux state rehydrated as Object
Logger.js:125 [modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for undefined
n @ Logger.js:125
Logger.js:125 [JitsiMeetJS.js] <Object.init>: Analytics disabled, disposing.
n @ Logger.js:125
Logger.js:125 [modules/statistics/AnalyticsAdapter.js] <e.value>: Disposing of analytics adapter.
n @ Logger.js:125
Logger.js:125 [modules/RTC/ScreenObtainer.js] <Object.init>: Desktop sharing disabled
Logger.js:125 [react/features/base/media/middleware.js] <>: Start muted:
Logger.js:125 [react/features/base/media/middleware.js] <>: Start audio only set to false
Logger.js:125 [react/features/base/conference/middleware.js] <>: Audio-only disabled
Logger.js:125 [modules/RTC/RTCUtils.js] <t.value>: Using the new gUM flow
Logger.js:125 [modules/xmpp/xmpp.js] <t.value>: P2P STUN servers: Array(3)
Logger.js:125 [modules/xmpp/xmpp.js] <t.value>: Lip-sync enabled !
Logger.js:125 [modules/xmpp/xmpp.js] <t.value>: (TIME) Strophe connecting: 2742.499999993015
Logger.js:125 [modules/RTC/RTCUtils.js] <t.>: Got media constraints: Object
Logger.js:125 [modules/RTC/RTCUtils.js] <>: Audio output device set to 7e615a0cb03c02637766ac9046845c6765feb0eea9e56f5829e212404bedd15c
Logger.js:125 [modules/RTC/RTCUtils.js] <>: onUserMediaSuccess
Logger.js:125 [react/features/base/storage/PersistenceRegistry.js] <e.value>: redux state persisted. 87d0e3f28504870d108d669d3d2b740b -> 4a95aa2f3adf93bc9100739da2885948
192.168.1.17/http-bind?room=cfml:1 Failed to load resource: net::ERR_CONNECTION_TIMED_OUT
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 1.1 error 0 happened
at Object.i.Strophe.log (strophe.util.js:89)
at Object.error (strophe.js:2083)
at e.Bosh._onRequestStateChange (strophe.js:5565)
n @ Logger.js:125
getGlobalOnErrorHandler @ JitsiMeetJS.js:535
window.onerror @ middleware.js:100
callErrorHandler @ GlobalOnErrorHandler.js:61
i.Strophe.log @ strophe.util.js:89
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request id 1.1 error 0 happened
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:90
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request errored, status: 0, number of errors: 1
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:77
warn @ strophe.js:2073
_hitError @ strophe.js:5382
_onRequestStateChange @ strophe.js:5566
strophe.js:5662 OPTIONS https://192.168.1.17/http-bind?room=cfml net::ERR_CONNECTION_TIMED_OUT
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 2.2 error 0 happened
at Object.i.Strophe.log (strophe.util.js:89)
at Object.error (strophe.js:2083)
at e.Bosh._onRequestStateChange (strophe.js:5565)
n @ Logger.js:125
getGlobalOnErrorHandler @ JitsiMeetJS.js:535
window.onerror @ middleware.js:100
callErrorHandler @ GlobalOnErrorHandler.js:61
i.Strophe.log @ strophe.util.js:89
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request id 2.2 error 0 happened
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:90
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request errored, status: 0, number of errors: 2
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:77
warn @ strophe.js:2073
_hitError @ strophe.js:5382
_onRequestStateChange @ strophe.js:5566
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
strophe.js:5662 OPTIONS https://192.168.1.17/http-bind?room=cfml net::ERR_CONNECTION_TIMED_OUT
l @ strophe.js:5662
(anonymous) @ strophe.js:5674
setTimeout (async)
_processRequest @ strophe.js:5672
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 3.3 error 0 happened
at Object.i.Strophe.log (strophe.util.js:89)
at Object.error (strophe.js:2083)
at e.Bosh._onRequestStateChange (strophe.js:5565)
n @ Logger.js:125
getGlobalOnErrorHandler @ JitsiMeetJS.js:535
window.onerror @ middleware.js:100
callErrorHandler @ GlobalOnErrorHandler.js:61
i.Strophe.log @ strophe.util.js:89
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
XMLHttpRequest.send (async)
l @ strophe.js:5662
(anonymous) @ strophe.js:5674
setTimeout (async)
_processRequest @ strophe.js:5672
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request id 3.3 error 0 happened
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:90
error @ strophe.js:2083
_onRequestStateChange @ strophe.js:5565
XMLHttpRequest.send (async)
l @ strophe.js:5662
(anonymous) @ strophe.js:5674
setTimeout (async)
_processRequest @ strophe.js:5672
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
Logger.js:125 [modules/xmpp/strophe.util.js] <Object.i.Strophe.log>: Strophe: request errored, status: 0, number of errors: 3
n @ Logger.js:125
i.Strophe.log @ strophe.util.js:77
warn @ strophe.js:2073
_hitError @ strophe.js:5382
_onRequestStateChange @ strophe.js:5566
XMLHttpRequest.send (async)
l @ strophe.js:5662
(anonymous) @ strophe.js:5674
setTimeout (async)
_processRequest @ strophe.js:5672
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577
XMLHttpRequest.send (async)
l @ strophe.js:5662
_processRequest @ strophe.js:5677
_throttledRequestHandler @ strophe.js:5823
_onRequestStateChange @ strophe.js:5577


#3

@Moula usually the problem is not opening/forwarding the ports or not setting jvb with its public address, you need to follow this section form the quick install https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration

I have no idea who wrote the document you are reading, but it is not complete. It assumes your machine has its public address, which most of the time is not the case.
The recommended doc for installing is the quick-install doc (link above) and you need to check the advanced configuration section.


#4

@damencho
Hi,
My installation is working when i access it locally with IP 192.168.1.17
Have followed the instructions for setting using NAT

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

DefaultLimitNOFILE=65000
DefaultLimitNPROC=65000
DefaultTasksMax=65000

But still it is not working when i try to access from outside with a static IP.

If i connect the server directly to the static ip ( that is disabling the NAT) where all do i need to change the settings for the system to work ?
Thanks in anticipation.
Vinod


#5

Bonjour Damencho.

Thank you for your answer.

My server is behind a DMZ.

My domain name and the certficat letsencrypt are accessible from the outside.

No worries it’s just when launching the camera and Audio.

Open Ports :

To Action From


22/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
22/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)

Thank you for your help.

Moula.

Le mar. 8 janv. 2019 à 16:34, Damian Minkov jitsi@discoursemail.com a écrit :


#6

Merci,

I will watch this and come back to you.

Moula.


Le mar. 8 janv. 2019 à 16:52, Vinod Rathi jitsi@discoursemail.com a écrit :


#7

the port forwarding was not set on the router.
did that and then it started working


#8

@damencho thank you very much. it work’s.

@Vinod I just added these two lines:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.....
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=8.....

Merci beaucoup.


Moula.

Le mer. 9 janv. 2019 à 07:04, Vinod Rathi jitsi@discoursemail.com a écrit :


#9

Hi Moula,
In my case I had added those lines but my router was blocking the ports. Changed the NAT settings to open the ports and it started working.