The Jibri record the entire desktop

I am using jibri the version stable-7439-2, but it recorded the entire desktop, and the vedio is under a tool tip.
Does it possible to record only the meeting contents by configuration, or any another way to solve that.


This is unfamiliar. Are you using the Local Recording feature?

The localRecording does not enabled.

Oh, that’s odd! I assume this is on Docker, right? Is this on arm or amd64? Did you make any changes to the jibri image?

I am using the amd64 docker image and not changed the image, also tried running on GCP, VirtualBox VM, but the result is the same.

How does your env file look like? Can you share the browser.txt log file?

the compose file with env configuration:

version: '3.5'

        image: jitsi/jibri:stable-7439-2
            - /home/jibri/jibri_1:/config:Z
            - /home/jibri/recordings:/recordings:Z
        shm_size: '2gb'
            - SYS_ADMIN
            - meet.jitsi:
            - CHROMIUM_FLAGS=--ignore-certificate-errors
            - DISPLAY=:0
            - ENABLE_STATS_D
            - JIBRI_XMPP_USER=jibri
            - JIBRI_XMPP_PASSWORD=71a9836b872db08887780618e4387619
            - JIBRI_BREWERY_MUC=jibribrewery
            - JIBRI_RECORDER_USER=recorder
            - JIBRI_RECORDER_PASSWORD=64904f25035743b78a1394b4ed2d9f30
            - JIBRI_RECORDING_DIR=/recordings
            - JIBRI_FINALIZE_RECORDING_SCRIPT_PATH=/config/defaults/ 
            - JIBRI_STRIP_DOMAIN_JID=muc
            - PUBLIC_URL=
            - TZ=UTC
            - XMPP_DOMAIN=meet.jitsi
            - XMPP_MUC_DOMAIN
            - XMPP_SERVER=meet.jitsi
            - XMPP_PORT
            - XMPP_TRUST_ALL_CERTS


browser.0.txt (3.2 MB)

This won’t work right. You need a valid TLS cert.

AFAIK this is expected behavior. I think your config somehow breaks Chromium default flags.

When I use the hostname and the certificate issued by letsencrypt and remove the “CHROMIUM_FLAGS=–ignore-certificate-errors environment variable”, it works fine.

Thank you for your great help!

I used the “CHROMIUM_FLAGS=–ignore-certificate-errors” environment variable to allow chromiun to accept self-signed certificates, which seems to be the reason for this recording.

Right. Then I know what happens. You need to define all options, that setting doesn’t add more options, it replaces them.

If you add these + yours, it should work: jibri/reference.conf at 260cee3a118462aa419ff3b2e0ca2ac4645b7a92 · jitsi/jibri · GitHub

Yes, when I changed to use all options, it record fine, could just use IP and self-signed credentials.
Thank you!


1 Like