The following packages contain unfulfilled dependencies

Hi all!
I’m trying to install Jitsi on my Debian buster server.
I have YunoHost installed on it but i’m trying to install near…

I have errors with the package and the installation can’t start.

The errors in french :

    Les paquets suivants contiennent des dépendances non satisfaites :
     jitsi-meet : Pré-Dépend: jitsi-videobridge2 (= 2.1-416-g2f43d1b4-1) mais ne sera pas installé
                  Dépend: jitsi-meet-prosody (= 1.0.4628-1) mais ne sera pas installé
                  Recommande: jitsi-meet-turnserver (= 1.0.4628-1) mais ne sera pas installé ou
                              apache2 mais ne sera pas installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Translation in english :

The following packages contain unfulfilled dependencies:
  jitsi-meet: Pre-Depends: jitsi-videobridge2 (= 2.1-416-g2f43d1b4-1) but will not be installed
               Depends: jitsi-meet-prosody (= 1.0.4628-1) but will not be installed
               Recommend: jitsi-meet-turnserver (= 1.0.4628-1) but will not be installed or
                           apache2 but will not be installed
E: Unable to correct problems, bad packets are in "keep as is" mode.

Do you some informations about theses errors?
I’m newbie on these manipulations, i’m learning… :blush:

Many thanks for your answers.
Kindly :wink:

Could you paste your /etc/apt/sources.list

And the output for the following. run as root

netstat -taunp
# deb cdrom:[Debian GNU/Linux 9.13 _Buster_ - Unofficial amd64 CD Binary-1 20200731-16:54]/ buster main no$

# deb cdrom:[Debian GNU/Linux 9.13 _Buster_ - Unofficial amd64 CD Binary-1 20200731-16:54]/ buster main no$

## YunoHost repository
deb http://forge.yunohost.org/debian/ buster stable

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://ftp.debian.org/debian buster-updates main contrib non-free
deb-src http://ftp.debian.org/debian buster-updates main contrib non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
#deb https://adoptopenjdk.jfrog.io/adoptopenjdk/deb/ buster main
# deb-src https://adoptopenjdk.jfrog.io/adoptopenjdk/deb/ buster main

bash: netstat : commande introuvable

Many thanks for your help :wink:

IIUC YunoHost is a server management system which has a web interface too. So jitsi and YunoHost want to control the web service at the same time and this causes the dependency problem.

I think using a plain Debian Buster will be better to install jitsi

1 Like

Indeed I think that the problem comes from there too … both want to go through the web service!
Many thanks, i will try to fin another solution. :blush: