"The description does not look like plan-b"

Hi. I’ve got a custom installation of Jitsi and we’re trying to figure out a difficult to catch problem. In tracking this, I’ve noticed that whenever I click on mic., the console gives the following warning: The description does not look like plan-b. This comes from the following in interop.js…

// Make sure this is a plan-b sdp.
        if (session.media.length > 3 || session.media.every(m => PLAN_B_MIDS.indexOf(m.mid) === -1)) {
            console.warn('The description does not look like plan-b');

            return description;
        }

Is this an indicator of anything going wrong?

No, this just means that your deployment is on Unified plan, which is where all deployments need to be by the end of the year because Plan B is being switched off. So, you’re good.

2 Likes

OK, thanks.

I’m looking to get help with this problem at this point and am looking for someone who is highly qualified and supremely knowledgeable with all things Jitsi. Know of anyone like this?

What problem? That message does not indicate a problem.

@Freddie
The problem is your avatar. It makes you look lowly qualified and supremely unknowledgeable

1 Like

@emrah Oh dear! :rofl:

1 Like

Don’t care about the icon, just care about getting it fixed. :grinning:

Problem: This happens in a reproducible way when FF is involved. It also happens on Chrome, but it is much less frequent and not reproducible.

Steps to reproduce…

  • One person on FF one on Chrome.
  • Both go on mic
  • Chrome user goes off mic, then on mic again
  • FF user cannot hear anymore but chrome user can still hear FF user

This does not happen on Jitsi meet though. That’s why I’m looking for someone who is " highly qualified and supremely knowledgeable".

@Freddie or @emrah : Would you be able to do some debugging with me on this? Would be happy to pay for your time, of course.

I have no idea about this subject

Hi gtilflm,

have you been able to solve that issue? maybe by upgrading Jitsi ?

The issue remains. I’m not sure why, but my main developer thinks it could be related to lib-jitsi-meet.

Thanks.

For what it is worth, I am facing a similar issue. This problem is still present with the current lib jitsi master commit.

In my case, the error does not happen anymore when using then enableUnifiedOnChrome: false option.
This is definitely not a long-term solution but can help to debug.

Interesting! Does Chrome, Safari, etc. still work fine with that setting?

Also, where would I find the enableUnifiedOnChrome option?

Depends who you asks. Plan b is deprecated in chrome. It was supposed to be totally discontinuated in chrome by the end of 2021. But as a website owner, you can ask for a delay until 25 of May . Origin Trials

I am using Jitsi as a lib, so I have it in the config starting the conference.
If you use the full Jitsi web interface, probably you can put it in the config.js file.

On Debian setup, the last config.js for the installation is under /usr/share/jitsi-meet-web-config/config.js:

grep -i unified config.js 
    // Enable unified plan implementation support on Chromium based browsers.
    // enableUnifiedOnChrome: false,
        // Enable unified plan implementation support on Chromium for p2p connection.
        // enableUnifiedOnChrome: false,

Note that the parameter suggests that the default value is false. However the code suggests that this suggestion is false - that is, default is true since mid 2021:

lib-jitsi-meet$ git show 4ed91b68c
commit 4ed91b68c5ddffdbd2f08e49c35cb3a43143089f
Author: Jaya Allamsetty <jaya.allamsetty@8x8.com>
Date:   Wed Jul 14 00:08:27 2021 -0400

    feat: Switch to unified plan on chrome by default unless explicitly disabled.

Well, we tried that and lost all audio. Perhaps we didn’t put it in the right place.

Thanks for weighing in though!

that ? you actually set enableUnifiedOnChrome to True and it changed something ? is your code base from mid 2021 then ?

FWIW: The developer helping me said, “we changed it to FALSE and it changes something. because chrome doesnt support plan b anymore”.

Well, this whole thread has a bad title then. Plan-B has nothing to do with because it’s a thing of the past, a relic from ancien times. The code should display instead; ‘The description looks like current, modern web - if it did not it would be a serious problem. All is well’. Or maybe nothing, in fact.