The audio in Jitsi Meet is badly distorted and broken up

I host a twice weekly video chat, a hangout for usually about 10 or 15 hobbyists like myself where we discuss topics of mutual interest. I use an HP desktop PC with a quad core AMD, 8 GB RAM, and adequate system resources. My broadband is 100 Mbps/10 Mbps, with no other sources of drain from any other household devices. I use a USB Logitech C-270 integrated Camera/Microphone which works well with Windows voice recorder and every other application I use it for.

This Distortion problem was non existent one day and has been plaquing my broadcast for the past 3 shows. In the following example, the audio from my microphone is broken up and distorted beyond recognition. Oddly, the incoming audio from my guests sounds exactly the same. My speakers at this time are the simple PC type that came with the computer. They plug in to the speaker RCA jack on the rear of the machine. Earbuds plugged into the front jack have the same problem. I’m completely baffled as to why the speakers AND mic have the same problem, as they seem like they are completely unrelated.

Here is a video I made without involving YouTube, just recording straight to my Dropbox folder from And it sounds just like this when I am streaming to the 'Tube. The same distortion happens if I use 8x8.

Next is an example of a live stream I sent straight to the 'Tube from YouTube Studio, without involving Jitsi. The mic and speakers both work fine.

I thought maybe it was a corrupt Windows update, but have had no luck tracking it down. In order to host my show now, I use the desktop computer to operate the Youtube Studio and chatbox, with its cam and mic disabled, and simultaneously join the show as a guest with my Asus tablet and earbuds so I can talk and listen. This works well except I can’t use the “Follow Me” function, and it’s kind of a pain in the ass. Please, any advice is welcome.

P.S. (I had moved to 8x8 wnen Jitsi continually said, “No Streamers are Available” for over a month. I came back to Jitsi when this problem arose and found Jitsi to be connecting again).

uh, welcome to the marvelous world of devices in Webrtc. Do you know what ? actually, having more is sometimes less. For example yesterday I did a test of running Jitsi client in a container. In the host I have 2 devices video0 and video1. One of them is phoney, I don’t have 2 cams, that’s the weird world of software I never took the time to track the reason.
In the host the client is picking the right device fine.
In the container I forwarded the 2 devices and it did not work. I forwarded the the working device video0 and it worked. The client software is the same in the host and the container. Go figure.

So in your case I’d try to disable enough to have only one device that could be used. If you can disable the sound on your webcam do so.
Also, it’s clear that there are 2 browsers out there and they have different devices capabilities. So give a spin to Firefox if you are using Chrome or Chrome if you are using Firefox. Or even try the electron version, it could be a slightly different version of the Chrome engine.

Hello, G. Patel
I’ve been using Chrome, so I’ll try Firefox and see what happens. I am not familiar with the electron version, so I’ll look it up. I also have Opera that I can try too. I used to love that browser back in its day.

I have a cheap old pencil mic that I can plug in for a test. I’ll switch them out one at a time and hope for the best. Thanks for the tips,