Terrible video quality (320p) after update

I have just installed fresh Jitsi server using your guide: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet

Now when I try to join a conference with another participant the image quality is always 320p. I have previously got 720p without any issue using the same setup and on the same server in Azure cloud. Problems started after updating to current stable version.

I checked video bridge logs and it was full of this kind of errors:

Unable to find encoding matching packet!

So maybe some kind of encoding error? I have configured the video to use 320p at minimum (and this worked in previous version I used):

video: {
height: {
ideal: 720,
max: 1080,
min: 320
frameRate: {
max: 24

Even if I raise the min-config to 720p I’m still only getting 320p. The local video seems to be 720p like it should, but remote video is always 320p.

Have you checked js browser console logs? Any errors there?

Yes I have. Not a single error in Chrome console logs.

Btw I’m using websocket if that helps at all. It worked previously without problems.

I am going to publish an article on this after the new year but I found out the my terrible video quality was being caused because of receiveMultipleVideoStreams and sourceNameSignaling. Disabling those fixed my quality issue.

    flags : {
         sourceNameSignaling : false,
         sendMultipleVideoStreams : false,

Thanks! I’ll try if this works for me when I’m back at work.

Actually sorry, the ability to make this modification was removed on Nov 8th in this commit: Remove support for legacy endpoint based signaling. (#2147) · jitsi/lib-jitsi-meet@7b25768 · GitHub

So if your version is newer of Jitsi after Nov 8th, that option won’t work. Here is my issue that I am putting in about the video quality in newer versions of Jitsi: Jitsi Multiple Video Streams and Source Signaling is Causing Lower Quality Videos