TALK_WHILE_MUTED is not getting triggered

Hi I’m trying to detect if someone is speaking while mic is off and tried to setup the event as follows:

But unfortunately its not getting triggered. Kindly suggest if there is anyway which I can try?

 room.addEventListener(JitsiMeetJS.events.conference.TALK_WHILE_MUTED, () => {
        console.log( "You look like on mute...." );
});

I have tried it all the way but there is no even getting triggered while I’m in mute but speaking…

room.addEventListener(JitsiMeetJS.events.track.TALK_WHILE_MUTED, () => {
console.log( “You look like on mute…” );
});

Make sure enableTalkWhileMuted is set to true in your config. Learn how to do this here:

I already have done this setup but still there is no event getting triggered. I’m sure there is some other setting which I’m missing.

I tried to debug it and following is the findings:

Its giving warning that we ddid not provide a VAD processor so no voice detection service will be provided.

No VAD Processor was provided. Talk while muted detection service was

Now after going through further documentation of the JITSI, we have a function where we need to pass an object and that object should implement few functions to process the voice specially the function calculateAudioFrameVAD(pcmSample) is complex one.

JitsiMeetJS.createTrackVADEmitter

This is a bit strange for me…Not sure if there is something else to make [TALK_WHILE_MUTED ], then please correct me otherwise its something like digging a well to drink the water…

I’m wondering about this community who is not willing even to look into others problem, everyone is asking his own questions…we ask our questions ourself do R&D ourself and find a solution ourself, JITSI developers are busy in their own world, they reply to a set of predefined people only…Anyway… :frowning:

What’s in your interface config? What’s in your other config.js? What version of Prosody do you have?

By the way this is a community for us. The developers are really busy and do not have time to read or respond to everything.

Thanks Corby for reply.

I’m using lib-jitsi-meet and TALK_WHILE_MUTED and NOISY MiC DETECTION are not triggering. I have tried all the way by setting enableTalkWhileMuted and tried capturing it in the following listener

conferenece.addEventListener(JitsiMeetJS.events.track.TALK_WHILE_MUTED, () => {
console.log( “You look like on mute…” );
});

If I turned on WARN messages, its giving following message:

No VAD Processor was provided. Talk while muted detection service was

Now I’m not sure how I can write VAD Processor…

Is this on Safari? If so, it looks like it’s disabled on Safari:

Actually. A few lines below that show the error you see: https://github.com/jitsi/lib-jitsi-meet/blob/3ac82faa2d6a0e09428b89409b1c89cce08904bf/JitsiConference.js#L411

No I’m using Google Chrome, and as mentioned in the code, it won’t even display warning message if it won’t go inside, it is going inside when enableTalkWhileMuted is set to true and it is not Safari. So it is going inside but its getting stuck at config.createVADProcessor which I believe we can’t provide from outside because in documentation as well, there is no any parameter given with a name createVADProcessor.

Have you tried on https://jit.si using the same browser and setting enableTalkWhileMuted in the URL?

I can tell you both mute and noise options do work. (just tested). I’m wondering if there is an issues with your hardware? First try on jit.si and then, if possible, maybe try a different computer on your site.

Yes they work perfectly fine in JITSI MEET, but looks like they are not available in JISTI LIB.