System Requirements to run Jitsi?

We’re looking to turn to Jitsi for out college classes, but after I brought it up, the coordinator told me that something important was that it should be democratic in terms of it being run properly in all computers.

In short, I want to know if there’s a basis in terms of operating system, processor, RAM, and all that (basic stuff) so that Jitsi runs properly without crashing everything to the ground. I mean, could it run on a sort of old computer? Mostly that.

I personally have no problem because my computer is pretty new, but some teachers don’t seem to have newer computers.

Please help! We want to change as soon as possible.