Switch to unified plan on Chrome

This is hard to be answered … you need and jicofo/bridge update … the UI now reports what is being shown so if there are videos outside the view area the bridge is not sending … so I would say just update to the latest stable jitsi-meet.
Maybe it is not easy, but the projects follow the pace of the browsers every 4 to 6 weeks you may expect new things, so you need to plan your changes in a way so you can easily update.
In maybe 2-3 years we had seen 3 times such a breaking change … and all users needed to update to latest.

1 Like

Do we need to upgrade JVB and Jibri server ?

Jicofo and jvb yes, its always good idea to keep the components in sync web, jicofo and jvb. Jibri is separate, but you better update that also to latest stable, there some changes about changes in dropbox api if you are using it… They changed stuff for handling tokens and next month meetings longer than 4 hours may have problem uploading

The current implementation called “Plan B” will be deprecated with the release of Chrome M93/94 this month. This was also discussed in the Jitsi community recently ?
What should we as a business take care of ? Is there a proper doc to analyse what is getting affected here and what versions will work post update ?
Please help me out here with more details

There is no doc, it was discussed on several occasions in the community call.
The last two stable releases had unified plan turned on by default. All you need is update to the latest.

1 Like

Please @Nishit_Rathi this is a public forum, let’s keep it public.
There is no list of changes to be pointed the work is spread between many components and was done in the last year or so … update to the latest lib-jitsi-meet jicofo and jvb in your test environment and see how it goes and ask here if you see problems and we will try to help.
What will be affected: chrome browser will no longer be able to join conferences.
There is an origin trial you can enable on your web to extend it to the end of the year:
https://developer.chrome.com/origintrials/#/view_trial/3892235977954951169

1 Like

Hi Saghul,

We are also hitting these issues with the latest Chrome.

Are you running the latest stable?

Hi Damencho,

It looks like the latest Jitsi we have is already supporting this when going straight to the room creation screen and making calls.
We, however are using the jitsi lib with custom front-end.
The Jitsi lib is imported with the @lyno npm, which just wraps the standard sdk. Not sure if that package is maintained by someone internal to the jitsi project?

No, it is not maintained by us, no idea about it. It is advised you source lib-jitsi-meet from your deployment so you make sure you are updating the version with the rest of the components otherwise you can face unpredictable problems.

@damencho I extended the origin trial on google chrome for my domain temporary (till I upgrade to latest jitsi meet). Any idea, where/how can I configure that token on haproxy/nginx server? Thanks!

In here jitsi-meet/head.html at master · jitsi/jitsi-meet · GitHub
You can add <meta http-equiv="origin-trial" content="....

3 Likes

Thanks, Damian, will do👍

I’ve upgraded to jitsi-meet 6726 and unified plan doesn’t seem to be active as Chrome reports the issue with plan B. In addition to the latest stable, is there changes to the configuration to make to enable it?

What version of Chrome are you running?

It’s Chrome 96, current latest

Hi @damencho
We have a custom UI using the the lib-jitsi-meet Jitsi APIs and everything was stable.

We encountered the Plan B error on chrome, so have upgraded jitsi components so they are on the Unified plan
The jitsi-meet install on our server now works fine with the upgrade so the upgrade has been successful, but our custom UI is facing issues now. The first authorised user see’s themselves only (local track), and then the subsequent users only see 2 tracks themselves (local track) and the authorised user , and do not see any other users.
So to summarise everyone sees the first authorised users remote track, but do not see any other remote tracks.

I am not sure if this has been caused by the unified update or not, but I see you mentioned there was changes made on the Jitsi-meet implementation, so could you advise of what changes we would need to do on the Custom GUI to enable unified or if you think this is possibly caused by something else, if you could suggest what it could be that would be great.

Thanks
J

Unified plan changes are all internal to lib-jitsi-meet and should not affect the UI implementation. The change is only how the remote tracks are represented in the session description passed to the browser but the track events are the same irrespective of the mode that the browser is running in. It would be hard to tell what is going wrong with your implementation without looking at the logs.

Hi Jaya,

Thanks for your reply which makes total sense

The Audio tracks for all participants were being added to the remote track object, but not the video
We have further check our implementation and it seems the creation local tracks is not in the order as described by the jitsi example use of the API and seems possible that the upgrade to the latest version of lib-jitsi-meet has tightened its logic around addition of the video track to the conference object.
We are in the process of reconfiguring order for it to match the jitsi documentation and hopefully this will resolve the issue.

Thanks
J

1 Like

Yep it was indeed that we called the API to create the local tracks too early, and earlier versions of lib-jitsi-meet was handling this but the updated ones are not.

Good to share in case anyone else comes across this issue whilst upgrading :slight_smile:

1 Like