Swift 5.3 error

Failed to build module ‘JitsiMeet’ from its module interface; the compiler that produced it, ‘Apple Swift version 5.3 (swiftlang-1200.0.29.2 clang-1200.0.30.1)’, may have used features that aren’t supported by this compiler, ‘Apple Swift version 5.3.1 (swiftlang-1200.0.41 clang-1200.0.32.8)’

How to resolve this
Tks

You have to get a version of xcode that supports Swift 5.3.

my Xcode Version 12.2 (12B45b)

Xcode 12 includes Swift 5.3

You say it doesn’t have Swift 5.3.1, I don’t see any other updates to do

Not what I said. I said you need to get a version of Xcode that has Swift 5.3 - the source code for JitsiMeet was compiled using that version, but your version (12.2) is bundled with Swift 5.3.1. You can downgrade your Xcode to Xcode 12 (from your current Xcode 12.2) to be able to compile the package, or you can search online for possible workarounds.

I figured I had to downgrade. Thank you very much

I downgraded to Xcode 12, but get the following. This problem makes it very restricting for developers, especially if they have to pull in multiple SDKs. Are there some settings that can be put on the JitsiMeet SDK to make it less restrictive? /…JitsiViewController.swift:2:8: error: failed to build module ‘JitsiMeet’ from its module interface; the compiler that produced it, ‘Apple Swift version 5.3.1 (swiftlang-1200.0.41 clang-1200.0.32.8)’, may have used features that aren’t supported by this compiler, ‘Apple Swift version 5.3 (swiftlang-1200.0.29.2 clang-1200.0.30.1)’

This is a Solutions
https://github.com/jitsi/jitsi-meet-ios-sdk-releases