Subtitles must be "forced" to be shown

Hello,
I’m trying to setup transcibe in Jigasi.

I read that:
“Only moderators/authenticated user can turn on caption, that’s why the button is visible only to those participants before the feature is turned on. After it is turned on in a conference, there is a visual indication that this is ongoing and the rest of the participants can turn them on if they want.”

My problem is: CC button is visible only to moderator. If he clicks the button nothing happens unless he put in the browser’s developer console:

APP.conference._room.setLocalParticipantProperty(‘transcription_language’,‘it-IT’);

Only who insert this command can see the subtitles and he has to be authenticated or a moderator.

Why? What’s wrong?

Thanks.

Thank you for this very fast reply.
In hiddenDomain I already have “recorder…” for jibri.
How could I add both service to hiddenDomain?
This is not very clear to me.

Thanks

configure the user transcriber(or you may choose any other user name) in the same domain and use transcriber user in sip communicator properties:

org.jitsi.jigasi.xmpp.acc.USER_ID=SOME_USER@SOME_DOMAIN
org.jitsi.jigasi.xmpp.acc.PASS=SOME_PASS
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

Thank you very much for your helpful answer.

Now, with hidden domain all partecipants can see transcriptions button. And for guests it works. Guests instead see correctly subtitles when they activated transcriptions after moderator.

But moderator that first enable transcriptions cannot see subtitles as long as he run in his browser console:

APP.conference._room.setLocalParticipantProperty('transcription_language','it-IT');

So, the questions are 2:

How to avoid APP.conference._room.setLocalParticipantProperty(‘transcription_language’,‘it-IT’) ?
How to change default language for transcriptions (the service is always in english and google doesn’t recognize foreign languages) ?

Another issue is that afer few minutes of jigasi running it raise an excpetion. After jigasi must be restarted at service level

WARNING: [179] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener() Connection XMPPBOSHConnection[transcriber@hiddendomain.xxx/05623fe8] (2) closed with error
org.igniterealtime.jbosh.BOSHException: Could not parse body:

504 Gateway Time-out

I am using latest nigthly build:
jigasi 1.1-174-gdf364fe-1
jitsi-meet 2.0.5707-1

Sorry @Igor_Rossetti I no have answer for your question but I have question for you if you please answer. Where inside developer konsole for browser I put this code to make it are work?

You might want to ask this on a new post as it is a new issue.

1 Like

I use Chromium.

CTRL + SHIFT + I to open developers tool

Select “console” tab and on the bottom, where the prompt “>” is located.

I hope I’m clear, ask more if you need.

1 Like

For bosh timeout error I solved with proxy_read_timeout setting in nginx

location = /http-bind {
proxy_pass http://localhost:5280/http-bind;
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host $http_host;
proxy_read_timeout 10000;
}

I also have this problem, subtitles appear only after calling ‘cc button’ and APP.conference._room.setLocalParticipantProperty in console.

I use latest nightly build

can we use it as global like let’s say someone has selected chinese then for everyone caption should come on chinese