Stuck on "...needs to user your microphone and camera." - Windows 8.1/Chrome 80.0.3987.149

To provide emergency patient care remotely due to the COVID-19 pandemic, we began trying out our own Jitsi server this morning. It works great for everyone except a specific subset of our users. They are all running Windows 8.1 with the latest version of Chrome. They go to our Jitsi website and allow access to both their mic and camera but Jitsi Meet never goes past the “Jitsi Meet needs to use your microphone and camera.” screen. Reloading also doesn’t get you connected to the conference. The same thing happens when trying to access meet.jit.si. These users are able to successfully use Firefox to access Jitsi but our organization mandates everyone use Chrome. Does anyone have any ideas of what might be cause this or some troubleshooting steps I could take?

3 Likes

Can you run the test on https://test.webrtc.org/ and send us the report. Thanks. We had seen and other reports like this one.

Here are the test.webrtc report links. I’m including one from Chrome and one from Firefox on the same PC. Firefox works but Chrome does not.

Chrome 80.0.3987.149
https://test.webrtc.org/report/AMIfv94xim5riIhrZixrW6Xmtq6kOEEo0mWKQ0qmnMtaPOE6Jjr7H2I3JOFV-PuQBQxuH2RRtofyYjMgV_UlyoY_4mDS0v6ebz5u1ZRh26qqNEdCNI2vphZR14yKtLCVQbhkDpkVEuDEgF1lLeYCqJ7kOW2rLF9SVQ

Firefox - 74.0
https://test.webrtc.org/report/AMIfv94EnxFU6_Jhq_bWtm1EJVVNYpnvz3NNJeDcive-DiDoY7b-4mbWTQnGW--VvDzba3hjd68nH1OHojc5YYFoRgL5607glQS_-ViMwaCyvTW7-TSS9YQ285HOip2T43AvMjWbMS6CM6y30h54kYGy_3rGVkDgQw

Also, I get a console error in Chrome that says “The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page.”

I’ve got the same problem on my PC running Windows 10 with Chromium. It works when I only allow access to the microphone without the camera. Maybe this will help with finding a solution.

I’ve got the same problem here with Windows 10 pro (64 bit) and Chrome.
Has anybody found a solution please?

I never ended up finding a solution beyond having our users use Firefox. This issue seemed to only affect Lenovo E550 laptops running Windows 8.1 for us. Not sure if this information helps.

Hi! Not being able to use Jitsy, though I enabled use of camera and mic.
SO Win 8.1. Firefox replies that I should use Chrome or Chromium, last version of Chrome does not recognize I gave permissions for both camera and mic.
My test results https://tinyurl.com/vyuj3se

“Jitsi Meet needs to use your microphone and camera" appeared only in Chrome or the chromium-based new Edge, not in Firefox or Nightly.
It appeared only with the server meet.jit.si , not with the open servers meet.golem.de or kuketz-meet.de (who simply did not send my video).
It happened on Windows 8.1 as well as Windows 10 insiders.

I got rid of it by uninstalling manycam 3.x , then installing manycam 2.6.0.65 instead. Everything is fine now. Hope my report triggers further ideas for investigating your particular systems.

Take care,
Yves

Yes, same issue for me too and @YvesKlein your solution definitely helped. I had a Camera software installed called YouCam and uninstalling that solved the problem for me in Chrome.

This is happening for me, too. Although there are ways to access it for different people, the reason I was planning to use it as an alternate to Zoom was that it was supposedly easier for everyone to connect with a simple link.

This is happening for me, too. Although there are ways to access it for different people, the reason I was planning to use it as an alternate to Zoom was that it was supposedly easier for everyone to connect with a simple link. With this thread showing all the additional steps that have to be taken for some, I’m going back to Zoom.