Stuck in "Something went wrong" loop once second member connected

…or sometimes second users gets (other user having connectivity issues), and main user (on the laptop where Jitsi is installed) shows no sign of a second user.

Installed on Parrot OS (debian), using this guide: https://www.howtoforge.com/tutorial/how-to-create-your-own-video-conference-using-jitsi-meet-on-ubuntu-1804/ Although I’ve also purged and used the quickstart guide on github at some point.

I run this:

/etc/init.d/jicofo restart && /etc/init.d/jitsi-videobridge restart && /etc/init.d/prosody restart

…then loadoad a meeting in browsers on 2 computers, one of them the install computer. Soon as I get the “something went wrong” on both computers I stop those services, and logs show this:

cat /var/log/jitsi/jicofo.log /var/log/jitsi/jvb.log | grep -i severe && cat /var/log/prosody/prosody.err

Jicofo 2018-12-10 11:03:15.889 SEVERE: [38] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
Jicofo 2018-12-10 11:03:15.904 SEVERE: [38] org.jitsi.jicofo.JitsiMeetConferenceImpl.log() Can not invite participant – no bridge available.
JVB 2018-12-10 11:03:23.762 SEVERE: [198] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.
Dec 10 11:02:51 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Dec 10 11:02:51 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

What I’ve tried:

Added to /etc/jitsi/videobridge/sip-communicator.properties

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.jitsi.XXXXXXXX.com/.*
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.168.31.140
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=XXX.103.242.216
(XXXXXs for anonimity)

Router was struggling to forward port 80 so I just used a “DMZ” option that forwards all ports. UFW set to this:

To Action From


22/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
127.0.0.1 22 ALLOW 127.0.0.1
22/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)

Netstat:

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN 25463/lua5.1
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 25463/lua5.1
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 1047/nginx: master
tcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN 25463/lua5.1
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 10476/sshd
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 1047/nginx: master
tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN 25463/lua5.1
tcp6 0 0 ::1:5347 :::* LISTEN 25463/lua5.1
tcp6 0 0 :::5222 :::* LISTEN 25463/lua5.1
tcp6 0 0 :::80 :::* LISTEN 1047/nginx: master
tcp6 0 0 :::5269 :::* LISTEN 25463/lua5.1
tcp6 0 0 :::22 :::* LISTEN 10476/sshd
tcp6 0 0 :::8888 :::* LISTEN 25371/java
tcp6 0 0 192.168.31.140:4443 :::* LISTEN 25417/java
tcp6 0 0 :::5280 :::* LISTEN 25463/lua5.1
udp 0 0 0.0.0.0:68 0.0.0.0:* 1958/dhclient
udp 0 0 0.0.0.0:5353 0.0.0.0:* 2805/chrome
udp 0 0 0.0.0.0:5353 0.0.0.0:* 2805/chrome
udp6 0 0 :::7138 :::* 25371/java
udp6 0 0 :::54473 :::* 1904/Preload.js --c
udp6 0 0 :::5353 :::* 2805/chrome
udp6 0 0 :::46670 :::* 25417/java
udp6 0 0 192.168.31.140:10000 :::* 25417/java

What am I doing wrong here?

Thanks!

Here are the full jitsi logs in case needed:

https://pastebin.com/2tGd1TnT

No one able to suggest anything for this? Would an Issue on Github be my best bet?

I believe this comes from an update or something like it, I had my setup working for months now, when this same behaviour started showing up.

Looking through it with no clue so far.

That’s interesting, not seeing anything like it in the Github issues but maybe we have an unusual setup.

Here are my versions of the important dependencies, if you’d like to compare versions:

sudo apt list --installed | grep -i 'jitsi-videobridge\|jicofo\|jitsi-meet-web\|jitsi-meet-web-config\|jitsi-meet-prosody\|procps\|openssl\|nginx\|nginx-extras\|nginx-full\|nginx-light\|prosody'

jicofo/stable,now 1.0-440-1 amd64 [installed,automatic]
jitsi-meet-prosody/stable,now 1.0.3081-1 all [installed,automatic]
jitsi-meet-web-config/stable,now 1.0.3081-1 all [installed,automatic]
jitsi-meet-web/stable,now 1.0.3081-1 all [installed,automatic]
jitsi-videobridge/stable,now 1093-1 amd64 [installed,automatic]
nginx/stable,now 1.14.1-1 all [installed]
openssl/stable,now 1.1.1a-1 amd64 [installed]
procps/stable,now 2:3.3.15-2 amd64 [installed]
prosody/stable,now 0.10.2-1 amd64 [installed,automatic]

What OS you on?

Hhhm. Seems like it’s the setup.

I run an *buntu 16.04 server

jicofo/unstable,now 1.0-444-1 amd64 [installed,automatic]
jitsi-meet-prosody/unstable,now 1.0.3113-1 all [installed,automatic]
jitsi-meet-web/unstable,now 1.0.3113-1 all [installed,automatic]
jitsi-meet-web-config/unstable,now 1.0.3113-1 all [installed,automatic]
jitsi-videobridge/unstable,now 1095-1 amd64 [installed,automatic]
libgnutls-openssl27/xenial-updates,now 3.4.10-4ubuntu1.4 amd64 [installed]
libprocps4/xenial-updates,xenial-security,now 2:3.3.10-4ubuntu2.4 amd64 [installed]
libxmlsec1-openssl/xenial,now 1.2.20-2ubuntu4 amd64 [installed,automatic]
openssl/xenial-updates,xenial-security,now 1.0.2g-1ubuntu4.14 amd64 [installed]
procps/xenial-updates,xenial-security,now 2:3.3.10-4ubuntu2.4 amd64 [installed]
prosody/xenial,now 0.9.10-1 amd64 [installed]

Same issue happen on my server today.
Was working fine for months
jitsi-meet=1.0.3229-1 jitsi-videobridge=1077-1 jicofo=1.0-425-1 jitsi-meet-web=1.0.2942-1 jitsi-meet-prosody=1.0.2942-1 jitsi-meet-web-config=1.0.2942-1.

Did reboot services seems to fix issue temporary .
But would be nice some one explain why this happens .

Service restart didn’t help me. What services are you restarting? Maybe I’ve missed one.

Thanks

I end up reboot ec2 server

Did that helped?
I mean, I tried that, no change.

videobridge is complaining about conection refused.

So it seems to me that basically is some new issue with autentication involving videobridge.

I’ve spinned a fresh install, with the same result. :thinking:
Seems like the default configuration is no longer the right one.

@damencho do you know something about this new videobridge issue?

Cheers!

I’ve looked up and

  • prosody (lua & focus) and jicofo password match
  • prosody lua and videobridge password match

I’ve set videobridge jvb_host from default empty to,

  • JVB_HOST=127.0.0.1
  • JVB_HOST=localhost

And yet I’m getting this,

JVB 2018-12-12 14:56:19.291 GRAVE: [29] org.jitsi.meet.ComponentMain.call().323 java.net.ConnectException: Conexión rehusada (Connection refused), host:jitsi.si-n.cc, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Conexión rehusada (Connection refused)
	at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
	at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
	at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
	at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:315)
	at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:300)
	at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.ConnectException: Conexión rehusada (Connection refused)
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
	at java.net.Socket.connect(Socket.java:589)
	at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)
	... 12 more
JVB 2018-12-12 14:56:19.800 GRAVE: [17] org.jitsi.videobridge.health.Health.log() Health check failed in 0ms:
java.lang.Exception: No XMPP components

UPDATE:

Hi!,
Check if manually setting localhost on your jitsi-videobridge.service file fixes the issue for you too.

Reported here:

Hi, thanks for the advice, this does sound promising, I don’t seem to have a jitsi-videobridge.service file though, in that dir or anywhere on my system. There are other .service files in there though, and jitsi-videobridge is definitely active.

I created the file and put
JVB_HOST=127.0.0.1
JVB_HOST=localhost
in it, but doesn’t seem to have had any effect. Might it be a difference in my OS? I’m using Parrot OS.

Oh. Yeah.
This is for systemd, specificaly for *buntu based systems.

Check your jvb service has the localhost flag (if everything is running on the same server).

Assuming the below is the process, it does appear to have a --host=localhost setting. All is running on the same server, does it look ok?

java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64 -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties -cp /usr/share/jitsi-videobridge/jitsi-videobridge.jar:/usr/share/jitsi-videobridge/lib/agafua-syslog-0.4.jar:/usr/share/jitsi-videobridge/lib/annotations-15.0.jar:/usr/share/jitsi-videobridge/lib/bccontrib-1.0.jar:/usr/share/jitsi-videobridge/lib/bcpkix-jdk15on-1.54.jar:/usr/share/jitsi-videobridge/lib/bcprov-jdk15on-1.54.jar:/usr/share/jitsi-videobridge/lib/callstats-java-sdk-5.0.0.jar:/usr/share/jitsi-videobridge/lib/cglib-nodep-2.2.2.jar:/usr/share/jitsi-videobridge/lib/commons-codec-1.6.jar:/usr/share/jitsi-videobridge/lib/commons-lang3-3.1.jar:/usr/share/jitsi-videobridge/lib/commons-logging-1.2.jar:/usr/share/jitsi-videobridge/lib/concurrentlinkedhashmap-lru-1.0_jdk5.jar:/usr/share/jitsi-videobridge/lib/core-2.0.1.jar:/usr/share/jitsi-videobridge/lib/dnsjava-2.1.7.jar:/usr/share/jitsi-videobridge/lib/dom4j-1.6.1.jar:/usr/share/jitsi-videobridge/lib/fmj-1.0-20161207.221530-23.jar:/usr/share/jitsi-videobridge/lib/gson-2.3.1.jar:/usr/share/jitsi-videobridge/lib/guava-15.0.jar:/usr/share/jitsi-videobridge/lib/httpclient-4.4.jar:/usr/share/jitsi-videobridge/lib/httpcore-4.4.jar:/usr/share/jitsi-videobridge/lib/ice4j-2.0.0-20181005.221549-11.jar:/usr/share/jitsi-videobridge/lib/jain-sip-ri-ossonly-1.2.98c7f8c-jitsi-oss1.jar:/usr/share/jitsi-videobridge/lib/java-dogstatsd-client-2.5.jar:/usr/share/jitsi-videobridge/lib/java-sdp-nist-bridge-1.1.jar:/usr/share/jitsi-videobridge/lib/javax.servlet-api-3.1.0.jar:/usr/share/jitsi-videobridge/lib/jbosh-0.9.0.jar:/usr/share/jitsi-videobridge/lib/jcip-annotations-1.0.jar:/usr/share/jitsi-videobridge/lib/jcl-core-2.8.jar:/usr/share/jitsi-videobridge/lib/jetty-client-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-continuation-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-http-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-io-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-proxy-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-rewrite-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-security-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-server-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-servlet-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-servlets-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-util-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/jetty-webapp-7.0.1.v20091125.jar:/usr/share/jitsi-videobridge/lib/jetty-xml-7.0.1.v20091125.jar:/usr/share/jitsi-videobridge/lib/jicoco-1.1-20180821.201527-7.jar:/usr/share/jitsi-videobridge/lib/jitsi-android-osgi-1.0-20180322.162617-2.jar:/usr/share/jitsi-videobridge/lib/jitsi-configuration-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-dnsservice-2.9-20150723.181644-1.jar:/usr/share/jitsi-videobridge/lib/jitsi-fileaccess-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-netaddr-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-packetlogging-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-protocol-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-protocol-jabber-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-protocol-media-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-resourcemanager-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-stats-1.0-20180523.024051-5.jar:/usr/share/jitsi-videobridge/lib/jitsi-ui-service-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jitsi-util-2.13.389bc25.jar:/usr/share/jitsi-videobridge/lib/jna-4.1.0.jar:/usr/share/jitsi-videobridge/lib/jnsapi-0.0.3-jitsi-smack4.2-3.jar:/usr/share/jitsi-videobridge/lib/jose4j-0.5.1.jar:/usr/share/jitsi-videobridge/lib/json-simple-1.1.1.jar:/usr/share/jitsi-videobridge/lib/jul-to-slf4j-1.7.7.jar:/usr/share/jitsi-videobridge/lib/jxmpp-core-0.6.0.jar:/usr/share/jitsi-videobridge/lib/jxmpp-jid-0.6.0.jar:/usr/share/jitsi-videobridge/lib/jxmpp-util-cache-0.6.0.jar:/usr/share/jitsi-videobridge/lib/libidn-1.15.jar:/usr/share/jitsi-videobridge/lib/libjitsi-1.0-20180904.192703-363.jar:/usr/share/jitsi-videobridge/lib/log4j-1.2.15.jar:/usr/share/jitsi-videobridge/lib/log4j-api-2.3.jar:/usr/share/jitsi-videobridge/lib/log4j-core-2.3.jar:/usr/share/jitsi-videobridge/lib/object-cloner-0.1.jar:/usr/share/jitsi-videobridge/lib/objenesis-2.2.jar:/usr/share/jitsi-videobridge/lib/okhttp-3.9.1.jar:/usr/share/jitsi-videobridge/lib/okio-1.13.0.jar:/usr/share/jitsi-videobridge/lib/orange-extensions-1.3.0.jar:/usr/share/jitsi-videobridge/lib/org.apache.felix.framework-4.4.0.jar:/usr/share/jitsi-videobridge/lib/org.apache.felix.main-4.4.0.jar:/usr/share/jitsi-videobridge/lib/org.osgi.core-4.3.1.jar:/usr/share/jitsi-videobridge/lib/osgi-over-slf4j-1.7.7.jar:/usr/share/jitsi-videobridge/lib/sdes4j-1.1.3.jar:/usr/share/jitsi-videobridge/lib/sdp-api-1.0.jar:/usr/share/jitsi-videobridge/lib/sigar-1.6.4.jar:/usr/share/jitsi-videobridge/lib/slf4j-api-1.7.7.jar:/usr/share/jitsi-videobridge/lib/slf4j-jdk14-1.7.7.jar:/usr/share/jitsi-videobridge/lib/slf4j-simple-1.6.1.jar:/usr/share/jitsi-videobridge/lib/smack-bosh-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-core-4.2.2-b1c107f.jar:/usr/share/jitsi-videobridge/lib/smack-debug-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-experimental-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-extensions-4.2.2-b1c107f.jar:/usr/share/jitsi-videobridge/lib/smack-im-4.2.2-b1c107f.jar:/usr/share/jitsi-videobridge/lib/smack-java7-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-legacy-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-resolver-javax-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-sasl-javax-4.2.1.jar:/usr/share/jitsi-videobridge/lib/smack-tcp-4.2.2-b1c107f.jar:/usr/share/jitsi-videobridge/lib/tinder-1.3.0.jar:/usr/share/jitsi-videobridge/lib/websocket-api-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/websocket-client-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/websocket-common-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/websocket-server-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/websocket-servlet-9.2.10.v20150310.jar:/usr/share/jitsi-videobridge/lib/weupnp-0.1.4.jar:/usr/share/jitsi-videobridge/lib/xml-apis-1.0.b2.jar:/usr/share/jitsi-videobridge/lib/xmlpull-1.1.3.4a.jar:/usr/share/jitsi-videobridge/lib/xpp3-1.1.4c.jar:/usr/share/jitsi-videobridge/lib/zrtp4j-light-3.2.0-jitsi-1-20150723.002345-1.jar org.jitsi.videobridge.Main --host=localhost --domain=jitsi.XXXXXXXX.com --port=5347 --secret=XXXXXXXX