Struggling with meet install on Ubuntu 18.04.4 LTS (can't find dependancies)

Hi guys
I’m struggling with jitsi-meet installation on a fresh Ubuntu 18.04.4 LTS
To make it short, after every previous configuration steps done, when I run the installation script of the full suit, I get an error message telling that dependencies aren’t available.
I dug a bit and it seems that universe repo isn’t available (of course I’ve already added jisti repo).
Tried to install it with sudo add-apt-repository universe but I get a sudo: add-apt-repository: command not found error.
When I run jitsi-meet installer, I get

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:

  • jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.4074-1) but it is not going to be installed*
  •          Recommends: jitsi-meet-turnserver (= 1.0.4074-1) but it is not going to be installed or*
    
  •                      apache2 but it is not going to be installed*
    

E: Unable to correct problems, you have held broken packages.

I’ve read tons of threads here or online but didn’t find any workaround.
Any idea how to solve that issue ?

Dave

Do you have universe as package repo?
From https://jitsi.org/qi:

On Ubuntu systems, Jitsi requires dependencies from Ubuntu's universe package repository. To ensure this is enabled, run apt-add-repository universe at the command-line.

Yes I’ve activated it in /etc/apt/sources.list
it’s:

deb http://ca.archive.ubuntu.com/ubuntu/ bionic universe
deb-src http://ca.archive.ubuntu.com/ubuntu/ bionic universe
deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb-src http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe

and the repo for jitsi-meet is already in /etc/apt/sources.list.d/jitsi-stable.list

Ok, I’ve refreshed Ubuntu installation and it seems to install now