Strophe: BOSH-Connection failed: improper-addressing

Hello,

I wrote a web app using lib-jitsi-meet
The web app works perfectly when I ran it with beta.meet.jit.si server and the following configuration

const serverURL = 'beta.meet.jit.si';
const options = {
  hosts: {
    domain: serverURL,
    muc: `conference.${serverURL}`,
  },
  serviceUrl: `https://${serverURL}/http-bind`,
  clientNode: `https://${serverURL}`,
};

Now I’m trying to run self-hosted Jitsi server with Docker Compose according to this guide - Self-Hosting Guide - Docker · Jitsi Meet Handbook I managed to run the containers and everything seems to work

I have changed the configuration accordingly to

const serverURL = 'localhost:8443';
const options = {
  hosts: {
    domain: serverURL,
    muc: `conference.${serverURL}`,
  },
  serviceUrl: `https://${serverURL}/http-bind`,
  clientNode: `https://${serverURL}`,
};

But when I’m trying to initialize the conference I’m getting the following error

Logger.js:154 2021-04-27T14:21:10.055Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: BOSH-Connection failed: improper-addressing

Any help appreciated

This is wrong … This will result “muc: conference.localhost:8443,”. You need to use there your meet.jitsi if I remember how docker was configured … but you can check it by accessing directly the config.js from your deployment.

Thanks @damencho

my config file shows

hosts: {
    // XMPP domain.
    domain: 'jitsi-meet.example.com',

    // When using authentication, domain for guest users.
    // anonymousdomain: 'guest.example.com',

    // Domain for authenticated users. Defaults to <domain>.
    // authdomain: 'jitsi-meet.example.com',

    // Focus component domain. Defaults to focus.<domain>.
    // focus: 'focus.jitsi-meet.example.com',

    // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
    muc: 'conference.jitsi-meet.example.com'
},

// BOSH URL. FIXME: use XEP-0156 to discover it.
bosh: '//jitsi-meet.example.com/http-bind',

// Websocket URL
// websocket: 'wss://jitsi-meet.example.com/xmpp-websocket',

// The name of client node advertised in XEP-0115 'c' stanza
clientNode: 'http://jitsi.org/jitsimeet',

I tried the following which I guess is wrong

const serverURL = 'localhost:8443';

const options = {
  hosts: {
    domain: 'jitsi-meet.example.com',
    muc: 'conference.jitsi-meet.example.com',
  },
  serviceUrl: `https://${serverURL}/http-bind`,
  clientNode: `https://${serverURL}`,
};

and I still get the same error, do I need to change jitsi-meet.example.com using env variable or something like that? is it possible to work with localhost as docker is currently running locally on my machine?

Thanks again

I got the same error only docker version .
did you get method to modify it?

Hello,

I have same error, can help me?

Hello,
Any resolution on this, I am also facing the same issue
Using docker for jitsi on my local system