Strophe: BOSH-Connection failed: improper-addressing

Thank you for your hard work.
First of all, I have configured ssl here, frontend and backend

My backend part uses docker-jitsi-meet, which is started in docker, and its configuration is as follows.

Directory where all configuration will be stored.

CONFIG=~/.jitsi-meet-cfg.

Exposed HTTP port.

HTTP_PORT=8000.

Exposed HTTPS port.

HTTPS_PORT=8443.

System time zone.

TZ=shanghai.
ENABLE_XMPP_WEBSOCKET=0.

Public URL for the web service (required).

PUBLIC_URL= https://wrtc195.haoleen.com:8443.
DOCKER_HOST_ADDRESS=192.168.1.195.
XMPP_CROSS_DOMAIN=true

My example.js configuration is as follows

const serverURL = ‘wrtc195.haoleen.com:8443’;
const options = {
hosts: {
domain: serverURL,
muc: conference.${serverURL},
},
bosh: //${serverURL}/http-bind,
};

Visit my web page with a certified address
https://wrtc195.haoleen.com:10086/
Get the result
Logger.js:154
2022-11-02T06:35:51.213Z [modules/xmpp/strophe.util.js] <mt.Strophe.log>: Strophe: BOSH-Connection failed: improper-addressing
The next few steps are
Connection Failed!

This should be the proof of the correct configuration of my certificate.
2022-11-02T06:52:24.008Z [modules/RTC/RTCUtils.js] onUserMediaSuccess

Because of the communication between docker containers, I also put them in a network segment to prevent possible network problems.

image
image

I really don’t know what’s wrong right now. At present, the back-end project with front-end launched by docker can be used normally in LAN.

Please do not create multiple posts either here or the issues tracker or in both places. There is no point.

const serverURL = ‘wrtc195.haoleen.com:8443’;
Why this is different than:

Visit my web page with a certified address
https://wrtc195.haoleen.com:10086/

Open the link https://wrtc195.haoleen.com:10086/config.js these are the settings that jitsi-meet passes to lib-jitsi-meet and you can use that. Your domain and muc settings are wrong.

What I know better is that this problem has been stuck for me for two days. Help

OK I tried to modify it in the way you said, as follows.

const serverURL = ‘wrtc195.haoleen.com:10086’;
const options = {
hosts: {
domain: serverURL,
muc: conference.wrtc195.haoleen.com,
},
bosh: https://${serverURL}/http-bind,
};

https://wrtc195.haoleen.com:10086/config.js
And I just clicked on the address I just mentioned. It’s no different from the usual. Where can I find special data to see this address?

Anyway, after I have modified it, I will try to run it and there has been no change before. I am not quite sure what link I have left out. This step of setting up muc, uh, is also in the forum to see how other people say how to set up, and I fill in this format.

Hello, by the way.
Excuse me many times.
options.domain = ‘‘meet.jitsi’’
Can I exchange it for my own?

If I can, where do I need to modify the front-end project? what changes do I need in the back-end docker project? please point out.

For example, I have a docker-enabled port 10000 and port 8080, which is not clear which is in charge of the background.
Because we want to deploy this project in the intranet, the background will use the docker foreground to write ui.
Hope for an answer. Help.

Why do you want to change it?
This is the default value for docker and it is internal one and does not matter for outside world

Because this one is probably going to be on the Intranet and we’re not going to be able to access the Internet and this address that I just saw is actually going to be able to access an ip in the United States or is this system not going to be able to deploy in the Intranet environment

If it can be deployed on the Intranet, I would like to know how to modify the.env configuration file of docker and the field of example.js of the front-end custom, etc., so that the front-end and back-end can be used together. Thanks Thanks

meet.jitsi domain is a internal and you don’t need it to access the deployment. There is no need to change that.

If you want to use a custom UI you need to rebuild the image.