Stream & Record simultaneously with 2 jibris

i spun a 2nd jibri VM up and changed the nickname in the config.json.

it registers in jicofo but i cant record & stream simultaneously

it says all “All recorders are busy”

but i can stream OR Record individually but not together

what am i doing wrong? do i need to add anything else?

attaching the logs and config files
jibr2.log.0.txt (13.9 KB) jibri1.config.txt (3.0 KB) jibri2.config.txt (3.0 KB) jicofo.log (47.5 KB) jvb.log (55.7 KB) prosody.log (44.3 KB) jibr1.log.0.txt (3.3 KB)

jitsi version Installed: 2.0.4447-1
jibri version Installed: 8.0-26-g8023696-1
prosody version Installed: 0.10.0-1build1
jicofo version Installed: 1.0-547-1
jvb version Installed: 2.1-178-ge68e6705-1
all unstable builds

UPDATE: Also tried with stable builds & still face the same issue

This tutorial will be of great use to you.

If you ever have any issues and wanna talk to our experts we are always available on telegram

I have no issues in recording OR streaming with a single jibri server…

but will take a look & if need be will reach out

thanks

your guide is missing the config.json editing part, in the jibri server. its where most mistakes are made & jibri doesnt work

Wow. OK. We will make that update. Will you consider joining our docs team?

you can use my files attached in 1st post to update that section, its pretty straightforward, use jibri1.config.txt as an example

How did you like the website? Any impressions?

well organized. i see a lot of potential…

Please give us a star on Github

It will keep the boys motivated

Thanks for your feedback. Means a lot!

Bump!! Can someone please help?

I also could use this functionality but did not find any information about on how to configure two jibris joining the same session. Any help is appreciated!

the configuration is easy to do

as per the instructions, just install another instance of jibri and the same config.json but for 1 section

    "control_muc": {
        "domain": "internal.auth.meet.mydomain.com",
        "room_name": "JibriBrewery",
        "**nickname": "jibri-server2**"

just change the nickname to something unique.

thats what the tutorial video says

BUT, it doesnt work. The jibri joins jitsi & jicofo says it has. But when i hit record 1st (it works) & then stream after i get “All streamers are busy” error and jicofo says no jibris availabe

if i do it the other way, i get “All recorders are currently busy”

but both jibris are fine.

So far no solution in sight.

@bbaldino

Do i need to delete this thread here and report it in github? looks like a bug to me.

I can’t help in solving the problem but I’d be very interested in the solution too. I can confirm that with 2 jibri running I can record OR stream 2 different rooms at the same time, but I cannot stream AND record the same room.

I just run this test: 1. started recording. 2 Stop recording 3. Copy from the log the ffmpeg command 4. start streaming 5. run a second ffmpeg instance while the other still runnig and got this error message:

root@jibriunione:/home/stefanormc# ffmpeg -y -v info -f x11grab -draw_mouse 0 -r 30 -s 1280x720 -thread_queue_size 4096 -i :0.0+0,0 -f alsa -thread_queue_size 4096 -i plug:cloop -acodec aac -strict -2 -ar 44100 -c:v libx264 -preset veryfast -profile:v main -level 3.1 -pix_fmt yuv420p -r 30 -crf 25 -g 60 -tune zerolatency -f mp4 /tmp/recordings/nfnknfvbohflxdzy/integralconstraintspledgenewly_contemp.mp4
ffmpeg version 3.4.6-0ubuntu0.18.04.1 Copyright © 2000-2019 the FFmpeg developers
built with gcc 7 (Ubuntu 7.3.0-16ubuntu3)
configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
libavutil 55. 78.100 / 55. 78.100
libavcodec 57.107.100 / 57.107.100
libavformat 57. 83.100 / 57. 83.100
libavdevice 57. 10.100 / 57. 10.100
libavfilter 6.107.100 / 6.107.100
libavresample 3. 7. 0 / 3. 7. 0
libswscale 4. 8.100 / 4. 8.100
libswresample 2. 9.100 / 2. 9.100
libpostproc 54. 7.100 / 54. 7.100
[x11grab @ 0x55c4c7972420] Stream #0: not enough frames to estimate rate; consider increasing probesize
Input #0, x11grab, from ‘:0.0+0,0’:
Duration: N/A, start: 1587568942.789634, bitrate: N/A
Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 1280x720, 30 fps, 1000k tbr, 1000k tbn, 1000k tbc
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cloop
[alsa @ 0x55c4c797c460] cannot open audio device plug:cloop (No such file or directory)
plug:cloop: Input/output error

The problem seems to be the lack of a second ALSA loop. Can this be solved adding a second one? and if yes, how?

cheers

since i have 2 separate jibris on 2 separate VMs this shouldn’t be an issue right?

wouldn’t it be easier to simply use ffmpeg option to have multiple outputs at the same time?
I have no experience with jitsi but some with ffmpeg and it shouldn’t be much of an issue to do so.

Where can I edit the command Jibri runs? (it could also be useful to change the 30fps setting that is rather useless in europe’s 25 fps tv environment)

BUMP @bbaldino

Please let me know if you can help me out with this…

How are you running the 2 Jibris? On totally separate machines?