Stop Jitsi From redirecting to sub domain on HTTPS

Hi All,
I am running jitsi under a subdomain with other redirects, working fine, however when I added a new subdomain which I will proxy back to my home network with my secure tunnel (HTTP works fine).

Q. How do I stop jitsi from redirecting the new subdomain to jitsi sub domain under HTTPS, I just need the new subdomain to be ignored by jitsi and allow my caddy install to assign its own SSL?

Any advice greatly welcomed.

Small update when I run certbot on the domain I get the below error

sudo: /var/lib/sudo/lectured is owned by uid 1000, should be 0
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Attempting to parse the version 1.5.0 renewal configuration file found at /etc/letsencrypt/renewal/jitsi.domain.com.conf with version 0.31.0 of Certbot. This might not work.
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for subdomain.domain.com
nginx: [emerg] “server_names_hash_bucket_size” directive is duplicate in /etc/nginx/sites-enabled/jitsi.domain.com.conf:1
Cleaning up challenges
nginx restart failed:
b’’
b’’