Still having problems joining meeting using Firefox

A full year after Jitsi declared it is fully compatible with Firefox, a friend and I tried it out. I’m on Windows 10, Firefox 94.0.1 (64-bit) and it says “Firefox is Up To Date”. My friend is running a Max and firefox is also up to date. We have both given Jitsi permission to access our cameras and microphones (in Firefox settings), and enabled pop-up windows, and everything every YouTube video recommended. She has strict tracking controls, I have standard. After clearing cache and cookies and restarting Firefox about a million times what we wound up with was this: When we enter the pre-meeting page, we now get a popup that asks if we will allow Jitsi access to our camera and microphone. We click “allow”. Then we each get an orange box under the pre-meeting controls that says “You need to enable camera and microphone access.” And weirdly, here things change: on my computer the microphone is active but the camera is stopped, and Jitsi says, “Failed to access your camera - Cannot use camera for an unknown reason. Failed to access video source.” On my friend’s Mac, the camera is on, but the microphone is off and inaccessible. She has a little camera icon to the left of the address bar, and I have a little microphone. If we hover over our respective icons, an info box says, “you have granted this website additional permissions.” clicking on the icons reveals that Jitsi is granted permission to access our cameras and microphones but… no. If we enter the meeting, she has a camera but no mic; I have a mic but no camera. If we stay in the pre-meeting room and exhale too forcefully it removes the permissions; if we reload the page it asks again, but we can say “yes” until we’re blue in the face and still can’t get both camera and microphone working.

Google Chrome works perfectly with no fuss.

Are we the only users having a problem? (P.s. thanks for fixing the Record to Dropbox problem!) I came in on the tail end of a lengthy conversation spanning many months, or was it years? And I was going to add my whiny complaint when I tried again and it worked! Yay.)

Any browser extensions? (Especially privacy-related extensions, blockers, etc.)

At my work, Firefox latest stable (currently 94) is one of the browsers we do regular automated tests of Jitsi Meet with, and it works fine (as fine as it can considering Firefox’s various WebRTC limitations and bugs, that is). It’s not exactly the same since I guess you are using so we might not be testing the exact same version of jitsi-meet, but I would guess there’s probably another factor involved in your experience.

You can try starting Firefox in Troubleshoot Mode (I think it’s Help → Troubleshoot Mode → Restart) which temporarily disables extensions and custom settings. If the issue doesn’t happen in that mode, then an extension or configuration issue is causing the problem.

1 Like

Last time I checked official Jitsi-meet policy about device capability and browsers was: if everything works on, it’s a Jitsi-meet problem. If not, it’s probably a device and/or browser problem. Last time I checked, is very much a hit and miss, it can not work correctly on and work on Jitsi.
As of Firefox, I have direct access to 3 Linux computers on Linux, Firefox can access cam and mic on 2 of them. Mic is not usable on the third, while it used to work.
The hardware has not changed, so it’s probably a config problem. Let me see (skip a few hours of furious debugging…), yes the config was hosed. How Chrome managed to work nonetheless is a mystery, but after having back a fully working sound on this Ubuntu system, Firefox sound works again for and my Jitsi test instance.
For a Windows computer, stuff is rarely hosed by users trying to hack their own system, but by driver bugs, updates, failed updates and corrections attemps, general installation of many conflicting softwares, bad stuff can also happen.

Note on full page tests for connectivity, this has no relevance to device access.
If you want to do a report, don’t forget to click the weird icon to the left of the big Start button that looks vaguely like an insect, it can be useful to download a bug report that you can attach to the issue (either for Firefox bugzilla, or on Jitsi-meet Github issues - there are specific issues for these device problems)

Hi, and thanks. I tried running in trouble-shooting mode and it seems to work fine, but I’m trying to get my friend to try it. I suspect that this is a case of Firefox normally providing a lot more privacy than Chrome, since, you know, Google is all about slurping up info about us, and the additional settings available in FF can lead to a case where we’re so safe we can’t do anything. I’m not as safety-conscious as my friend, but even I probably had some thing set. I dread the possibility that the problem was caused by driver bugs, etc., the list you gave below. Much easier if it’s just custom settings that are too restrictive. I’m going to just try going forward with no custom settings, and only my password manager, see how that works.

Ellen Schwartz

@ellenschwartz maybe edit out your #?

1 Like

if you mean by that everything is fine on the test site of, then clean your Firefox install and try again with all extensions disabled as suggested. Maybe uninstall and do a clean install. If it still does not work, you should post an issue on Github since it could be a Jitsi-meet problem. Maybe add the report from

About Mac user I’d suggest to try with the official browser for this platform, it would probably be the best supported option. Not sure if there are many Firefox users on Mac.

I didn’t try the test site, just started FF in troubleshooting mode and launched a Jitsi Meeting, and had no trouble with camera or mic. Then I took a look at installed add-ons to the browser and decided, ugh. If the only problem is with Jitsi, I’ll just run it in troubleshoot when I’m using Jitsi and for other sites leave all my add-ons and settings. A crude workaround rather than a fix. I’m basically just exploring it for my friends who are too technophobic to run Zoom. As for my Mac friend, she uses Firefox because the built-in browser doesn’t offer enough protections, and she has extremely stringent settings. I can’t save her from herself. Thank you all for your advice. I’ll try to track down the actual problem on my Firefox some time when I have fewer other chores yapping at my heels.

I faced similar issue from last couple of hours, Please help me.