Still able to join the room with the expired token

from my booking table
which is in date format,

then it is down to you to convert it to the correct date format. How you do that is down to what language/framework you’re working with, and frank, is going beyond the scope if this thread.

1 Like

im using nestjs (typescript),

As I mentioned above, as much as I would like to help, asking for assistance on how to format dates in you programming language of choices is beyond the scope of this thread/community.

I am pretty sure there are plenty of resource out there on how to format date strings using typescript or modules specific to nestjs. (For example, nestjs-date-format-interceptor - npm which is the first thing I found by googling for “nestjs datetime format”. I have never used it, but the toISOString example looks promising)

Please do not take this the wrong way as I am saying this with no ill will or disrespect, but please do not abuse the helpfulness of others and be mindful that everyone is doing this voluntarily in their limited free time. Keep questions within the scope of the forum, and do your own investigation first before resorting to posting questions.

1 Like

thank u so much , yes understood

hi, the information u provided was helpful , I was going through some isses as well,but thus below configuration

VirtualHost “jitmeet.example.com
– …
modules_enabled = {
– …
“reservations”;
}
reservations_api_prefix = “http://reservation.example.com

where we gonn add this ? in /etc/prosody/conf.avail/example.meet.lua or in prosdy.cfd.lua?
cuz here How to configure reservation rest API they were tallking abt giving thre config in jicofo/sip-communicator.properties, please advise. thank u

I added in jicofo sip communtior as well and when enter the room it shouts this error
image
cant we check teh reservation with localhost neh, it has to be delyed right.

That depends on which version of Jitsi you are using. The reservations prosody plugin as documented here is probably the way to go going forward, but may not yet be available in latest stable release since it was only merged into master in mid May.

The posts that mentions Jicofo references the Reservation implementation in Jicofo that should be available for now but will be dropped eventually.

If you want to test your APIs using your existing Jitsi setup, your options are:

  1. use the Jicofo setup for now but bear in mind you’d need to migrate off it eventually.
  2. manually add the prosody plugin to your current setup. You just need to copy mod_reservations.lua to /usr/share/jitsi-meet/prosody-plugins/ and follow the instructions as usual in the doc.

You will want to use the prosody plugin or Jicofo one, not both.

Not sure I understand what you mean here. But from the error message it sounds like you’ve configure the URL to localhost:3000 that is not accepting connections?

1 Like

yes, im running my api in my localhost 3000 . so only once its tested only i can deploy, but the connenction is refused,

I’m afraid I know nothing about the application you wrote and deployed, so not sure how I can help.

I would suggest you first test your application independently first. Make sure you can connect to it yourself before trying it with jitsi.

1 Like

true, and yes i can able to connect to it, my question is can v actually test the reservation with locally hosted api?

yes. It shouldn’t matter where the API is hosted as long as it is accessible. Localhost should work.

1 Like

Got it thanks alot, and correct me if im wrong,

this has to be in /etc/prosody/prosody.cfg.lua? right?

or in /etc/prosody/conf.avail/exmaple.cfg.lua

^ here

1 Like

thanks alot, i will figure this out

:+1:t4: no problem. Good luck with your setup, and have fun with Jitsi!

1 Like

reservations_api_prefix = " http://localhost:3000/v1/jitsi-reservations"
i provided as this, anything wring in my link, i ddnt give /conference at the end, actual api is http://localhost:3000/v1/jitsi-reservations/conference.

That looks correct, apart from the space inside the quotes.

1 Like

for ur infomartion if remove org.jitsi.impl.reservation.rest.BASE_URL=http://localhost:3000/v1/jitsi-reservations from jocofo/sip-communitor and only have in prosody/conf.avail, jitsi is not even considering the resevation, jocofo/sip-communitor if i add her only its triggerig the resevation