startWithAudioMuted: true, & startWithVideoMuted: true, not working in 2.0.5390-3

Hi guys!

Neighter startWithAudioMuted: true, , nor startWithVideoMuted: true, work with the latest release.
Greped in the code, trying to see, where those get evaluated and even tried 0, 1, & 2 instead of “true” but this didn’t brought any success.
I can enable the prejoin-page, but still need to be able to toggle those default to OFF as required in the environment/country, where we use the instance.

Any help or hint would be highly appreciated!

Works for me, same version. Moderator starts with video and audio, guests without.
But I use the other config parameter (startAudioMuted):

    // Start the conference in audio only mode (no video is being received nor
    // sent).
    // startAudioOnly: false,

    // Every participant after the Nth will start audio muted.
    startAudioMuted: 1,

    // Start calls with audio muted. Unlike the option above, this one is only
    // applied locally. FIXME: having these 2 options is confusing.
    // startWithAudioMuted: false,

the same for video.

I am having the same issue after an update to the mentioned version last weekend. Would be great if anyone had more insight on this!

I am having the same issue as well. This is a make or break issue for us because of privacy policy regulations.

I realy hope we can get a solution asap.

Thank you.

Well, thanks for all the replies, but older versions of jitsi, that we still use mute works also for the moderator (first one in a room). This is as mentioned above a major issue and I can not push this thru the data protection audit, no matter how hard I would try to justify. Leaves me with no option of using the new version and people would drift away to a commercial solution. :confused:

Sorry for addressing You directly, @damencho , but is this on purpose that way?

Best regards

oh good grief, I’m sure that this has already been posted. Please read it and follow the indications to work around this problem.

Thanks @gpatel-fr , means I was too lazy or dull to read it in github.
Jitsi Meet startWithAudioMuted/startWithVideoMuted temporary fix · GitHub is one ugly, quick and durty approach, but I WILL try it out, just need to find some spare time and translate it to nginx.
Thanks again!

Using Jitsi Meet 2.0.5390-3

startWithAudioMuted still has issues. Is there a update schedule in near future ?

Using startAudioMuted works for all participants after the first one.

Try setting startAudioMuted: 0, in config.js as a work around. That seems to work for me. You will be unmuted when you are alone in the room. When the first person joins, both will be muted (until you unmute yourself).

this also happens with me.

this suggests startWithAudioMuted is not working only startAudioMuted: 0, is working. if startWithAudioMuted is working then even there is only one participant in the meet he should start a call by muting his microphone

This actually started working expected after I updated to the latest release.